[swift-users] Need better name, want to hide generator

Rob Mayoff mayoff at dqd.com
Sat Dec 19 00:08:26 CST 2015

> 1. Can anyone recommended a better name than Cartesian? 2D doesn't work
> for the compiler and I'm looking for something that doesn't seem
> "floating-point"-y

"AllPairs" seems self-explanatory.

"CrossJoin" should be intuitive to anyone familiar with relational

"product" sounds like it might be multiplying elements with each other.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20151219/56b7ca1a/attachment.html>

More information about the swift-users mailing list