<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class="">IMHO both ‘HTTPRequestHandling' and ‘HTTPRequestHandler' conform to the Swift API Design Guidelines, the ability to handle HTTP requests is a capability after all.</div><div class=""><br class=""></div><div class="">However, there’s just something about the name ‘HTTPRequestHandling' which seems… off… Maybe because the word “handling” is a verb (in the present-tense no less)? To make it an adjective it would have to be named something like: “HandlesHTTPRequests”. But that would be in breach of the style guidelines.</div><div class=""><br class=""></div><div class="">Is it just me, or is the current usage of ‘HTTPRequestHandler’ identifier wasted on syntactic sugar for the relatively unlikely scenario where a closure is provided to HTTPServing.start()? Perhaps the identifier could be used for the protocol instead, and the method that takes a closure could wrap the closure in a class implementing the protocol? Would look something like so:</div><div class=""><br class=""></div><div class=""><font face="Menlo" class="">&nbsp; &nbsp;&nbsp;public&nbsp;func&nbsp;start(port:&nbsp;Int&nbsp;=&nbsp;0, handler:&nbsp;HTTPRequestHandler)&nbsp;throws&nbsp;{<br class="">&nbsp; &nbsp; &nbsp; &nbsp;&nbsp;try&nbsp;server.start(handler: handler)<br class="">&nbsp; &nbsp; }</font></div><div class=""><font face="Menlo" class=""><br class=""></font></div><div class=""><font face="Menlo" class="">&nbsp; &nbsp;&nbsp;public&nbsp;func&nbsp;start(port:&nbsp;Int&nbsp;=&nbsp;0, _&nbsp;handlingClosure:&nbsp;@escaping&nbsp;HTTPRequestHandlingClosure)&nbsp;throws&nbsp;{<br class="">&nbsp; &nbsp; &nbsp; &nbsp;&nbsp;try&nbsp;self.start(handler: HTTPRequestHandlingClosureWrapper(handlingClosure))<br class="">&nbsp; &nbsp; }</font></div><div class=""><br class=""></div><div class="">Cheers,</div><div class="">Andrew.<br class=""></div></body></html>