<html><head><style>body{font-family:Helvetica,Arial;font-size:13px}</style></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">Well I only used the previously mentioned names, in my codebase I use `isFalse` for that situation which is better then `== false` in my opinion.</div> <br> <div id="bloop_sign_1515870428926558976" class="bloop_sign"></div> <br><p class="airmail_on">Am 13. Januar 2018 um 20:06:21, Karl Wagner (<a href="mailto:razielim@gmail.com">razielim@gmail.com</a>) schrieb:</p> <blockquote type="cite" class="clean_bq"><span><div><div></div><div>
<br>
<br>&gt; On 12. Jan 2018, at 20:54, Alejandro Martinez via swift-evolution &lt;swift-evolution@swift.org&gt; wrote:
<br>&gt;  
<br>&gt; I wouldn't go as far as to ask to fade out ! but in all my code I end
<br>&gt; up doing == false just for readability. That ! knows who to hide
<br>&gt; himself too well :P
<br>&gt;  
<br>
<br>Yeah so do I. ! is a very narrow character and totally changes the meaning of the logic.
<br>
<br>That said, I can’t come up with a clearer name than “== false”. inverted() isn’t helpful. toggle() on a mutable Bool is good, though.
<br>
<br>- Karl
<br>
<br>&gt; On Fri, Jan 12, 2018 at 10:13 AM, Adrian Zubarev via swift-evolution
<br>&gt; &lt;swift-evolution@swift.org&gt; wrote:
<br>&gt;&gt; I’m not sure if this would be considered or not, but I would like if the
<br>&gt;&gt; negation operator `!` would fade out.
<br>&gt;&gt;  
<br>&gt;&gt; If this is ever going to a review then I’d suggest that we add a pair of
<br>&gt;&gt; functions, one mutating and the other non-mutating.
<br>&gt;&gt;  
<br>&gt;&gt; extension Bool {
<br>&gt;&gt;  mutating func invert() {
<br>&gt;&gt;    self = !self
<br>&gt;&gt;  }
<br>&gt;&gt;  
<br>&gt;&gt;  func inverted() {
<br>&gt;&gt;    return !self
<br>&gt;&gt;  }
<br>&gt;&gt; }
<br>&gt;&gt;  
<br>&gt;&gt; I’d rather use `inverted` instead of `!` because of the readability this
<br>&gt;&gt; function provides.
<br>&gt;&gt;  
<br>&gt;&gt; if !items.contains(item) { ... }
<br>&gt;&gt;  
<br>&gt;&gt; if items.contains(item).inverted() { ... }
<br>&gt;&gt;  
<br>&gt;&gt; ——
<br>&gt;&gt;  
<br>&gt;&gt; I personally have some other extensions like:
<br>&gt;&gt;  
<br>&gt;&gt; extension Bool {
<br>&gt;&gt;  @discardableResult
<br>&gt;&gt;  func whenTrue&lt;T&gt;(execute closure: () throws -&gt; T) rethrows -&gt; T? {
<br>&gt;&gt;    if self { return try closure() }
<br>&gt;&gt;    return nil
<br>&gt;&gt;  }
<br>&gt;&gt;  
<br>&gt;&gt;  @discardableResult
<br>&gt;&gt;  func whenFalse&lt;T&gt;(execute closure: () throws -&gt; T) rethrows -&gt; T? {
<br>&gt;&gt;    if !self { return try closure() }
<br>&gt;&gt;    return nil
<br>&gt;&gt;  }
<br>&gt;&gt; }
<br>&gt;&gt;  
<br>&gt;&gt; But this is more a personal preference.
<br>&gt;&gt;  
<br>&gt;&gt; ——
<br>&gt;&gt;  
<br>&gt;&gt; That said, if the community is fine with the `invert/inverted` pair then I’d
<br>&gt;&gt; say go for it ;)
<br>&gt;&gt;  
<br>&gt;&gt; Am 12. Januar 2018 um 09:14:22, Nate Cook via swift-evolution
<br>&gt;&gt; (swift-evolution@swift.org) schrieb:
<br>&gt;&gt;  
<br>&gt;&gt;  
<br>&gt;&gt; On Jan 12, 2018, at 12:15 AM, Chris Eidhof via swift-evolution
<br>&gt;&gt; &lt;swift-evolution@swift.org&gt; wrote:
<br>&gt;&gt;  
<br>&gt;&gt; Hey SE!
<br>&gt;&gt;  
<br>&gt;&gt; When we have a bunch of nested structs:
<br>&gt;&gt;  
<br>&gt;&gt;    struct Sample {
<br>&gt;&gt;        var bar: Bar
<br>&gt;&gt;    }
<br>&gt;&gt;  
<br>&gt;&gt;    struct Bar {
<br>&gt;&gt;        var show: Bool
<br>&gt;&gt;    }
<br>&gt;&gt;  
<br>&gt;&gt;    var foo = Sample(bar: Bar(show: false))
<br>&gt;&gt;  
<br>&gt;&gt; It can be repetitive to toggle a deeply nested boolean:
<br>&gt;&gt;  
<br>&gt;&gt;    foo.bar.show = !foo.bar.show // duplication
<br>&gt;&gt;  
<br>&gt;&gt; I sometimes add a `toggle` extension on `Bool`
<br>&gt;&gt;  
<br>&gt;&gt;    extension Bool {
<br>&gt;&gt;        mutating func toggle() {
<br>&gt;&gt;            self = !self
<br>&gt;&gt;        }
<br>&gt;&gt;    }
<br>&gt;&gt;  
<br>&gt;&gt; This allows you to write the same code without duplication, and makes the
<br>&gt;&gt; intent clearer:
<br>&gt;&gt;  
<br>&gt;&gt;    foo.bar.show.toggle()
<br>&gt;&gt;  
<br>&gt;&gt;  
<br>&gt;&gt; I like it!
<br>&gt;&gt;  
<br>&gt;&gt; In other languages, I don't think the `toggle` would make as much sense, but
<br>&gt;&gt; the mutable self makes this very useful.
<br>&gt;&gt;  
<br>&gt;&gt; After I posted it on Twitter, it turns out I'm not the only one:
<br>&gt;&gt; https://twitter.com/PublicExtension/status/730434956376346624
<br>&gt;&gt;  
<br>&gt;&gt; I would have gone straight to a proposal, but I think we can do some
<br>&gt;&gt; bikeshedding about the name of `toggle`?
<br>&gt;&gt;  
<br>&gt;&gt;  
<br>&gt;&gt; Another verb that could work is `invert`.
<br>&gt;&gt;  
<br>&gt;&gt; The `!` operator that does this is the negation operator, but I think
<br>&gt;&gt; `negate` could sound to some like "make this false" rather than toggling.
<br>&gt;&gt;  
<br>&gt;&gt; Nate
<br>&gt;&gt; _______________________________________________
<br>&gt;&gt; swift-evolution mailing list
<br>&gt;&gt; swift-evolution@swift.org
<br>&gt;&gt; https://lists.swift.org/mailman/listinfo/swift-evolution
<br>&gt;&gt;  
<br>&gt;&gt;  
<br>&gt;&gt; _______________________________________________
<br>&gt;&gt; swift-evolution mailing list
<br>&gt;&gt; swift-evolution@swift.org
<br>&gt;&gt; https://lists.swift.org/mailman/listinfo/swift-evolution
<br>&gt;&gt;  
<br>&gt;  
<br>&gt;  
<br>&gt;  
<br>&gt; --  
<br>&gt; Alejandro Martinez
<br>&gt; http://alejandromp.com
<br>&gt; _______________________________________________
<br>&gt; swift-evolution mailing list
<br>&gt; swift-evolution@swift.org
<br>&gt; https://lists.swift.org/mailman/listinfo/swift-evolution
<br>
<br></div></div></span></blockquote></body></html>