<html><head><style>body{font-family:Helvetica,Arial;font-size:13px}</style></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">All I meant is that it’s usage should fade, which is my personal opinion. That said, I didn’t meant to say it should be removed or something. ;)</div> <br> <div id="bloop_sign_1515786900351390720" class="bloop_sign"></div> <br><p class="airmail_on">Am 12. Januar 2018 um 20:54:16, Alejandro Martinez (<a href="mailto:alexito4@gmail.com">alexito4@gmail.com</a>) schrieb:</p> <blockquote type="cite" class="clean_bq"><span><div><div></div><div>I wouldn't go as far as to ask to fade out ! but in all my code I end
<br>up doing == false just for readability. That ! knows who to hide
<br>himself too well :P
<br>
<br>On Fri, Jan 12, 2018 at 10:13 AM, Adrian Zubarev via swift-evolution
<br>&lt;swift-evolution@swift.org&gt; wrote:
<br>&gt; I’m not sure if this would be considered or not, but I would like if the
<br>&gt; negation operator `!` would fade out.
<br>&gt;
<br>&gt; If this is ever going to a review then I’d suggest that we add a pair of
<br>&gt; functions, one mutating and the other non-mutating.
<br>&gt;
<br>&gt; extension Bool {
<br>&gt;   mutating func invert() {
<br>&gt;     self = !self
<br>&gt;   }
<br>&gt;
<br>&gt;   func inverted() {
<br>&gt;     return !self
<br>&gt;   }
<br>&gt; }
<br>&gt;
<br>&gt; I’d rather use `inverted` instead of `!` because of the readability this
<br>&gt; function provides.
<br>&gt;
<br>&gt; if !items.contains(item) { ... }
<br>&gt;
<br>&gt; if items.contains(item).inverted() { ... }
<br>&gt;
<br>&gt; ——
<br>&gt;
<br>&gt; I personally have some other extensions like:
<br>&gt;
<br>&gt; extension Bool {
<br>&gt;   @discardableResult
<br>&gt;   func whenTrue&lt;T&gt;(execute closure: () throws -&gt; T) rethrows -&gt; T? {
<br>&gt;     if self { return try closure() }
<br>&gt;     return nil
<br>&gt;   }
<br>&gt;
<br>&gt;   @discardableResult
<br>&gt;   func whenFalse&lt;T&gt;(execute closure: () throws -&gt; T) rethrows -&gt; T? {
<br>&gt;     if !self { return try closure() }
<br>&gt;     return nil
<br>&gt;   }
<br>&gt; }
<br>&gt;
<br>&gt; But this is more a personal preference.
<br>&gt;
<br>&gt; ——
<br>&gt;
<br>&gt; That said, if the community is fine with the `invert/inverted` pair then I’d
<br>&gt; say go for it ;)
<br>&gt;
<br>&gt; Am 12. Januar 2018 um 09:14:22, Nate Cook via swift-evolution
<br>&gt; (swift-evolution@swift.org) schrieb:
<br>&gt;
<br>&gt;
<br>&gt; On Jan 12, 2018, at 12:15 AM, Chris Eidhof via swift-evolution
<br>&gt; &lt;swift-evolution@swift.org&gt; wrote:
<br>&gt;
<br>&gt; Hey SE!
<br>&gt;
<br>&gt; When we have a bunch of nested structs:
<br>&gt;
<br>&gt;     struct Sample {
<br>&gt;         var bar: Bar
<br>&gt;     }
<br>&gt;
<br>&gt;     struct Bar {
<br>&gt;         var show: Bool
<br>&gt;     }
<br>&gt;
<br>&gt;     var foo = Sample(bar: Bar(show: false))
<br>&gt;
<br>&gt; It can be repetitive to toggle a deeply nested boolean:
<br>&gt;
<br>&gt;     foo.bar.show = !foo.bar.show // duplication
<br>&gt;
<br>&gt; I sometimes add a `toggle` extension on `Bool`
<br>&gt;
<br>&gt;     extension Bool {
<br>&gt;         mutating func toggle() {
<br>&gt;             self = !self
<br>&gt;         }
<br>&gt;     }
<br>&gt;
<br>&gt; This allows you to write the same code without duplication, and makes the
<br>&gt; intent clearer:
<br>&gt;
<br>&gt;     foo.bar.show.toggle()
<br>&gt;
<br>&gt;
<br>&gt; I like it!
<br>&gt;
<br>&gt; In other languages, I don't think the `toggle` would make as much sense, but
<br>&gt; the mutable self makes this very useful.
<br>&gt;
<br>&gt; After I posted it on Twitter, it turns out I'm not the only one:
<br>&gt; https://twitter.com/PublicExtension/status/730434956376346624
<br>&gt;
<br>&gt; I would have gone straight to a proposal, but I think we can do some
<br>&gt; bikeshedding about the name of `toggle`?
<br>&gt;
<br>&gt;
<br>&gt; Another verb that could work is `invert`.
<br>&gt;
<br>&gt; The `!` operator that does this is the negation operator, but I think
<br>&gt; `negate` could sound to some like "make this false" rather than toggling.
<br>&gt;
<br>&gt; Nate
<br>&gt; _______________________________________________
<br>&gt; swift-evolution mailing list
<br>&gt; swift-evolution@swift.org
<br>&gt; https://lists.swift.org/mailman/listinfo/swift-evolution
<br>&gt;
<br>&gt;
<br>&gt; _______________________________________________
<br>&gt; swift-evolution mailing list
<br>&gt; swift-evolution@swift.org
<br>&gt; https://lists.swift.org/mailman/listinfo/swift-evolution
<br>&gt;
<br>
<br>
<br>
<br>--  
<br>Alejandro Martinez
<br>http://alejandromp.com
<br></div></div></span></blockquote></body></html>