<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Jan 2, 2018 at 11:45 PM, Nevin Brackett-Rozinsky via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div><div class="h5">On Tue, Jan 2, 2018 at 9:07 PM, Jordan Rose via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div>[Proposal: <a href="https://github.com/apple/swift-evolution/blob/master/proposals/0192-non-exhaustive-enums.md" style="font-family:Helvetica,arial,sans-serif" target="_blank">https://github.com/<wbr>apple/swift-evolution/blob/mas<wbr>ter/proposals/0192-non-exhaust<wbr>ive-enums.md</a>]</div><div><br></div><div>Whew! Thanks for your feedback, everyone. On the lighter side of feedback—naming things—it seems that most people seem to like &#39;<b>@frozen</b>&#39;, and that does in fact have the connotations we want it to have. I like it too.</div><div><br></div><div>More seriously, this discussion has convinced me that it&#39;s worth including what the proposal discusses as a <b>&#39;future&#39; case</b>. The key point that swayed me is that this can produce a <i>warning</i> when the switch is missing a case rather than an <i>error,</i> which both provides the necessary compiler feedback to update your code and allows your dependencies to continue compiling when you update to a newer SDK. I know people on both sides won&#39;t be 100% satisfied with this, but does it seem like a reasonable compromise?</div><div><br></div><div>The next question is how to spell it. I&#39;m leaning towards `unexpected case:`, which (a) is backwards-compatible, and (b) also handles &quot;private cases&quot;, either the fake kind that you can do in C (as described in the proposal), or some real feature we might add to Swift some day. `unknown case:` isn&#39;t bad either.</div><div><br></div><div>I too would like to just do `unknown:` or `unexpected:` but that&#39;s technically a source-breaking change:</div><div><br></div><blockquote style="margin:0px 0px 0px 40px;border:none;padding:0px"><div>switch foo {</div><div>case bar:</div><div>  unknown:</div><div>  while baz() {</div><div>    while garply() {</div><div>      if quux() {</div><div>        break unknown</div><div>      }</div><div>    }</div><div>  }</div><div>}</div></blockquote><div><br></div><div>Another downside of the `unexpected case:` spelling is that it doesn&#39;t work as part of a larger pattern. I don&#39;t have a good answer for that one, but perhaps it&#39;s acceptable for now.</div><div><br></div><div>I&#39;ll write up a revision of the proposal soon and make sure the core team gets my recommendation when they discuss the results of the review.</div><div><br></div><div>---</div><div><br></div><div><div>I&#39;ll respond to a few of the more intricate discussions tomorrow, including the syntax of putting a new declaration inside the enum rather than outside. Thank you again, everyone, and happy new year!</div></div><div><br></div><div>Jordan</div></div></blockquote><div><br></div><div><br></div></div></div><div>+1 to warning instead of error<br></div><div>+1 to unknown/unexpected case</div><div>+1 to “@frozen” or any other reasonable spelling, they are all fine by me.</div></div></div></div></blockquote><div><br></div><div>+1 to “@tangled” because abi is complicated<br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div><br></div><div>The one remaining problem to solve is making sure multi-module apps can leave out the unknown/unexpected case on enums from modules which are part of the app itself and thus cannot be updated independently of it. John McCall’s version-locking plan sounds promising, though we should explore the available options before finalizing a course.</div><div><br></div><div>Perhaps we need a concept of submodules, or supermodules, or some other way to demarcate the boundaries of a resilience domain.</div><div><br></div><div>Nevin</div></div></div></div></blockquote><div><br></div><div>i would support a proper submodule system over some verson-locking system that only the most advanced users will probably know about. i think modules should be one level higher than what they’re currently being used for right now for lack of a better alternative (one application should never have to define more than one capital M Module). submodules shouldn’t be that hard to implement, though the submodule names should be part of ABI to avoid name mangling problems<br></div></div><br></div></div>