<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title></title>
</head>
<body>
<div name="messageBodySection" style="font-size: 14px; font-family: -apple-system, BlinkMacSystemFont, sans-serif;">Happy to hear that we went in this direction! Looking forward to the compact method as well.</div>
<div name="messageSignatureSection" style="font-size: 14px; font-family: -apple-system, BlinkMacSystemFont, sans-serif;"><br />
Jarod</div>
<div name="messageReplySection" style="font-size: 14px; font-family: -apple-system, BlinkMacSystemFont, sans-serif;"><br />
On Dec 19, 2017, 08:56 -0800, John McCall via swift-evolution &lt;swift-evolution@swift.org&gt;, wrote:<br />
<blockquote type="cite" style="margin: 5px 5px; padding-left: 10px; border-left: thin solid #1abc9c;">
<div class="">Hi, Swift community! &#160;I apologize for the delay in reporting our decision here; between one holiday and the other, it took awhile for the core team to assemble a quorum to talk through this.</div>
<div class=""><br class="" /></div>
Proposal Link:&#160;<a href="https://github.com/apple/swift-evolution/blob/master/proposals/0187-introduce-filtermap.md" class="">https://github.com/apple/swift-evolution/blob/master/proposals/0187-introduce-filtermap.md</a><br class="" />
<br class="" />
The second review of SE-0187 “Introduce Sequence.filterMap(_:)” ran from November 15...20, 2017. &#160;The result of the first review was consensus to rename the method, and the purpose of the second review was to get more specific feedback on what the new name should be.
<div class=""><br class="" /></div>
<div class="">"filterMap" is a name with some precedent in other programming languages, especially functional ones, but some people felt strongly that the name was misleading because, as a combined operation, it wasn't quite a filter or a map. &#160;Of the alternatives, the one with the strongest support seemed to be "compactMap", which builds on the precedent of "compact", an operation from other languages (notably Ruby) which returns a copy of the input without nil values. &#160;Swift does not currently have such an operation, and in fact it is not currently possible to express it; nonetheless, the core team agrees that it would be a reasonable operation to add, and that "compactMap" is a good name for the operation.</div>
<div class=""><br class="" /></div>
<div class="">Therefore, SE-0187 is <b class="">accepted</b>, with the <b class="">revision</b> that the new name be Sequence.compactMap(_:), and with the agreement that we will add Sequence.compact() when it is possible to do so.<br class="" />
<br class="" />
Thank you all for your continued contributions to making Swift a better language.</div>
<div class=""><br class="" />
John McCall<br class="" />
Review Manager&#160;<br class="" /></div>
</blockquote>
</div>
</body>
</html>