This is an excellent proposal and a worthy addition. The problems addressed are significant and these changes in general fit well with the direction of Swift. One nit below, but otherwise I think this will be pretty great.<br><br>Nit:<br><br>merge(_:mergingValues:) and friends should be more consistent with other closure labels as revised in SE-0118. Some options:<br><br>merge(_:mergingValuesBy:) // the "by" is used consistently in similar closure labels<br>merge(_:combiningValuesBy:) // avoids repeating the word "merge"<br>merge(_:makingValueWith:) // by analogy with ManagedBuffer.create(minimumCapacity:makingValueWith:)<br>merge(_:by:) // as with earlier versions of SE-0118, worth considering if the more verbose labels "do much to enhance readability at the point of use"<br><br><div class="gmail_quote"><div dir="ltr">On Wed, Apr 5, 2017 at 19:45 Ben Cohen via swift-evolution <<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word;line-break:after-white-space" class="gmail_msg">Hello, Swift community!<br class="gmail_msg"><br class="gmail_msg">The review of "SE-165: Dictionary & Set Enhancements" begins now and runs through next Tuesday, April 11th. The proposal is available here:<div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span><a href="https://github.com/apple/swift-evolution/blob/master/proposals/0165-dict.md" class="gmail_msg" target="_blank">https://github.com/apple/swift-evolution/blob/master/proposals/0165-dict.md</a></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><div class="gmail_msg">Reviews are an important part of the Swift evolution process. All reviews should be sent to the swift-evolution mailing list at</div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span><a href="https://lists.swift.org/mailman/listinfo/swift-evolution" class="gmail_msg" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">or, if you would like to keep your feedback private, directly to the review manager. When replying, please try to keep the proposal link at the top of the message:</div><div class="gmail_msg"><div class="gmail_msg"><br class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>Proposal link: <span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span><a href="https://github.com/apple/swift-evolution/blob/master/proposals/0165-dict.md" class="gmail_msg" target="_blank">https://github.com/apple/swift-evolution/blob/master/proposals/0165-dict.md</a></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>Reply text</div><div class="gmail_msg"><br class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>Other replies</div></div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><b class="gmail_msg">What goes into a review?</b><br class="gmail_msg"><br class="gmail_msg">The goal of the review process is to improve the proposal under review through constructive criticism and, eventually, determine the direction of Swift. When writing your review, here are some questions you might want to answer in your review:<br class="gmail_msg"><br class="gmail_msg"><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>• What is your evaluation of the proposal?<br class="gmail_msg"></div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>• Is the problem being addressed significant enough to warrant a change to Swift?<br class="gmail_msg"></div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>• Does this proposal fit well with the feel and direction of Swift?<br class="gmail_msg"></div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>• If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?<br class="gmail_msg"></div><div class="gmail_msg"><span class="m_-856642069092569713Apple-tab-span gmail_msg" style="white-space:pre-wrap">        </span>• How much effort did you put into your review? A glance, a quick reading, or an in-depth study?<br class="gmail_msg"></div><div class="gmail_msg"><br class="gmail_msg"></div>More information about the Swift evolution process is available at <a href="https://github.com/apple/swift-evolution/blob/master/process.md" class="gmail_msg" target="_blank">https://github.com/apple/swift-evolution/blob/master/process.md</a><div class="gmail_msg"><br class="gmail_msg"><div class="gmail_msg">Thank you,<br class="gmail_msg"><br class="gmail_msg">Ben Cohen<br class="gmail_msg">Review Manager</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><br class="gmail_msg"></div></div></div></div></div>_______________________________________________<br class="gmail_msg">
swift-evolution mailing list<br class="gmail_msg">
<a href="mailto:swift-evolution@swift.org" class="gmail_msg" target="_blank">swift-evolution@swift.org</a><br class="gmail_msg">
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" class="gmail_msg" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br class="gmail_msg">
</blockquote></div>