<html><head><meta http-equiv="Content-Type" content="text/html charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">I agree that the current form is better than the old way, but a lot of Swift's syntax is based around trying to be friendly for new programmers (remember removal of ++ and --?), and the form `x throws -&gt; y` reads a lot like `x can throw y`, since the arrow is pointing between the two. I just would like some way to make it explicitly clear to those who have not had years of experience with Swift that `throws` is a standalone modifier.<br class=""><div class="">
<div style="color: rgb(0, 0, 0); letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px; word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class="">-thislooksfun (tlf)</div>

</div>

<br class=""><div style=""><blockquote type="cite" class=""><div class="">On Dec 26, 2016, at 12:41 PM, Derrick Ho &lt;<a href="mailto:wh1pch81n@gmail.com" class="">wh1pch81n@gmail.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><div class="">I personally do not see anything wrong with its current placement.<br class="gmail_msg"><br class="gmail_msg">It may be there because it was based on an existing cocoa pattern from objective-c<br class="gmail_msg"><br class="gmail_msg">- (NSString *)bazWithError:(NSError **)error { ... }</div><div class=""><br class=""></div><div class="">Because objective c could only return one thing, using pointer-to-pointer was needed to deliver more than one.</div><div class=""><br class=""></div><div class="">When swift came along it became this...</div><div class=""><br class=""></div><div class="">func baz(error: NSErrorPointer) -&gt; String</div><div class=""><br class=""></div><div class="">The style felt old-fashioned and was replaced with throw.</div><div class=""><br class=""></div><div class="">func baz() throws -&gt; String</div><div class=""><br class=""></div><div class=""><br class=""></div><div class="">The evolution is consistent.&nbsp; The pattern is familiar.&nbsp; I think we should keep the placement of throw as it is.</div><div class=""><br class="gmail_msg"><div class="gmail_quote gmail_msg"><div class="gmail_msg">On Mon, Dec 26, 2016 at 9:38 AM thislooksfun via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" class="gmail_msg" target="_blank">swift-evolution@swift.org</a>&gt; wrote:<br class="gmail_msg"></div><blockquote class="gmail_quote gmail_msg" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word" class="gmail_msg">Hello Swifters,<div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">I've been writing a lot more Swift code recently, and I have found that the default placement of the 'throws' declaration is often confusing, especially to those of us switching from languages where the type of errors thrown is explicitly defined (like Java)</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">For example,</div><div class="gmail_msg"><div class="gmail_msg m_7524104568081187879m_-7031938144007969227bloop_markdown" style="font-family:Helvetica,Arial;font-size:13px;background-color:rgb(254,254,254)"><pre style="margin-top:15px;margin-bottom:15px;font-family:Menlo,Consolas,'Liberation Mono',Courier,monospace;font-size:10pt;border-top-left-radius:3px;border-top-right-radius:3px;border-bottom-right-radius:3px;border-bottom-left-radius:3px;background-color:rgb(248,248,248);color:inherit;border:1px solid rgb(204,204,204);overflow:auto;padding:4px 8px;word-break:normal;word-wrap:normal" class="gmail_msg">// This is pretty clear, this can throw an error<br class=""><br class="">func foo() throws<br class=""><br class="">{ ... }<br class=""><br class=""><br class=""><br class="">// Also pretty clear, this returns a String<br class=""><br class="">func bar() -&gt; String<br class=""><br class="">{ ... }<br class=""><br class=""><br class=""><br class="">// Confusing. Does this throw a String? Does it return a String? Does it do both?<br class=""><br class="">// I personally keep reading this as 'this can throw a String'<br class=""><br class="">func baz() throws -&gt; String<br class=""><br class=""><br class=""><br class="">// Equivalent code in Java (not a model, just for clarification of why the above is confusing)<br class=""><br class="">String baz() throws StringFormatException</pre></div><div class="gmail_msg">I therefore suggest either tweaking the syntax around, or moving, the `throws` keyword to avoid this confusion.</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">Some ideas I've had:</div><div class="gmail_msg"><pre style="color:inherit;margin-top:15px;margin-bottom:15px;font-family:Menlo,Consolas,'Liberation Mono',Courier,monospace;font-size:10pt;border-top-left-radius:3px;border-top-right-radius:3px;border-bottom-right-radius:3px;border-bottom-left-radius:3px;background-color:rgb(248,248,248);border:1px solid rgb(204,204,204);overflow:auto;padding:4px 8px;word-break:normal;word-wrap:normal" class="gmail_msg">// Add a comma to separate them<br class=""><br class="">func baz() throws, -&gt; String<br class=""><br class=""><br class=""><br class="">// Move `throws` to the end<br class=""><br class="">func baz() -&gt; String throws<br class=""><br class=""><br class=""><br class="">// Change it to a prefix modifier (like `mutating`)<br class=""><br class="">throwing func baz() -&gt; String<br class=""><br class=""></pre></div><div class="gmail_msg">I'm still not sold on any of the above syntaxes, but I would love to hear your feedback.</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg">This would affect existing code, but it would be a fairly small change that would result in very large readability improvements, especially for newcomers, and <i class="gmail_msg">especially</i>&nbsp;for those coming for a language such as Java.</div><div class="gmail_msg"><br class="gmail_msg"></div><div class="gmail_msg"><div style="letter-spacing: normal; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px; word-wrap: break-word;" class="gmail_msg">-thislooksfun (tlf)</div><br class=""><br class=""><br class=""><br class=""></div><br class=""><br class=""><br class="gmail_msg"></div></div>_______________________________________________<br class="gmail_msg"><br class=""><br class="">swift-evolution mailing list<br class="gmail_msg"><br class=""><br class=""><a href="mailto:swift-evolution@swift.org" class="gmail_msg" target="_blank">swift-evolution@swift.org</a><br class="gmail_msg"><br class=""><br class=""><a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" class="gmail_msg" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br class="gmail_msg"><br class=""><br class=""></blockquote></div></div>
</div></blockquote></div><br class=""></body></html>