<div dir="ltr">Why can&#39;t we just remove distinction between operator and identifier symbols? I&#39;d be fine with the following:<div><br></div><div>```swift</div><div>infix operator map</div><div>infix func map(lhs: [Int], rhs: (Int) -&gt; Int) { ... }</div><div>[1,2,3] map {$0*2}</div><div>```</div><div><br></div><div>No explicit imports required, plus we can create nice DSLs. Of course, it&#39;s an additive change, but it&#39;s worth considering right now, because it can remove some headache caused by current distinction.</div></div>