<div dir="ltr">The framework design guidelines were for ensuring code consistency and necessarily included stylistic decisions. There was no ban on using explicit interface implementation, just reasonable caution to the end goal of consistency. This is what the framework design guidelines said in 2010: <a href="https://msdn.microsoft.com/en-us/library/ms229034(v=vs.100).aspx">https://msdn.microsoft.com/en-us/library/ms229034(v=vs.100).aspx</a><div>A web search suggests that the current version of the guidelines contains no guidance on explicit interface implementation, but could be that I just couldn&#39;t find it.</div><div>Explicit implementations were essential for moving collection interfaces and others to generic versions - there&#39;s plenty of uses in the Microsoft .Net framework implementation - so I would be surprised if there was a feeling that the feature was a mistake, but you&#39;d have to ask Anders and others. (I don&#39;t know if TypeScript has a similar feature, but if not, there are alternative explanations for it&#39;s absence than thinking it was a mistake for C#).</div><div><br></div><div>You&#39;re correct that C# doesn&#39;t allow renaming: it requires the interface name to be prefixed to the method name at the point of definition.</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Aug 23, 2016 at 4:03 PM, Xiaodi Wu <span dir="ltr">&lt;<a href="mailto:xiaodi.wu@gmail.com" target="_blank">xiaodi.wu@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><span class="">On Tue, Aug 23, 2016 at 5:51 PM, Callionica (Swift) <span dir="ltr">&lt;<a href="mailto:swift-callionica@callionica.com" target="_blank">swift-callionica@callionica.<wbr>com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">C# has this feature (called &quot;explicit interface implementation&quot; or &quot;explicit interface method implementation&quot;). It&#39;s useful for implementing multiple data-like interfaces that have common names like Name, ID, Title, and Description. It&#39;s useful for keeping public interfaces clean. It&#39;s useful for API evolution: sometimes you need to implement both IVersion1 and IVersion2 interfaces that have (as you would expect) similar method names and semantics, but differences that still require different implementations.<div><br></div><div>There&#39;s a stack overflow topic which has various perspectives on it: <a href="http://stackoverflow.com/questions/143405/c-sharp-interfaces-implicit-implementation-versus-explicit-implementation" target="_blank">http://stackoverflow.com/q<wbr>uestions/143405/c-sharp-interf<wbr>aces-implicit-implementation-<wbr>versus-explicit-implementation</a></div></div></blockquote><div><br></div></span><div>This is very interesting information. The OP there, dating from &#39;08, states: &quot;Microsoft&#39;s official guidelines (from first edition Framework Design Guidelines) states that using explicit implementations are not recommended.&quot; Is that, to your knowledge, still the consensus opinion from Microsoft? If the language designers of C# were to do it all over again, would this feature have been added at all?</div><div><br></div><div>Two notable considerations. In this proposal, Jonathan is suggesting that we _rename_ protocol requirements; I don&#39;t think C# EIMI has that feature, so it would remain to be determined whether this new twist could be an improvement or a regression as compared to EIMI.</div><div><br></div><div>Second, invoking an EIMI member requires creating an interface instance. In Swift, however, protocols that have Self or associated type requirements can only be used as generic constraints. It is unclear to me if or how the Swift type system would represent something analogous to an interface instance.</div><div><div class="h5"><div><br></div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div class="gmail_extra"><div class="gmail_quote"><div><div>On Tue, Aug 23, 2016 at 8:35 AM, Xiaodi Wu via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br></div></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div><div><div dir="ltr"><span>On Tue, Aug 23, 2016 at 3:02 AM, Jonathan Hull <span dir="ltr">&lt;<a href="mailto:jhull@gbis.com" target="_blank">jhull@gbis.com</a>&gt;</span> wrote:<br></span><div class="gmail_extra"><div class="gmail_quote"><span><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><br><div><span><blockquote type="cite"><div>On Aug 22, 2016, at 11:32 PM, Xiaodi Wu &lt;<a href="mailto:xiaodi.wu@gmail.com" target="_blank">xiaodi.wu@gmail.com</a>&gt; wrote:</div><br><div><div dir="ltr">On Mon, Aug 22, 2016 at 11:59 PM, Jonathan Hull via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hi everyone,<br>
<br>
We talked about this before when we were discussing mixins, and there seemed to be generally positive feelings towards it as a feature for the future.</blockquote><div><br></div><div>It&#39;s been some time now since the original discussion, so perhaps you could refresh our collective memory (or at least, mine): although it *seems* like this feature might be useful, I can&#39;t recall a concrete use case where I&#39;ve felt like I needed this feature--do you have some examples?</div></div></div></div></div></blockquote><div><br></div></span><div>Ideally, the biggest use is that it helps to (partially) solve the diamond problem (and similar issues) by forcing/allowing disambiguation when there are multiple protocols being conformed to.  This will become more of an issue if we allow protocols or extensions to add storage.  Your proposed syntax actually does a better job of it than mine because mine was always shown as attached to some sort of implementation, whereas yours could potentially allow access to a default implementation under a new name.</div><div><br></div><div>Other than that, it generally allows us to bypass/mitigate conflicts between protocols.  In the current version, you are unable to conform to both protocols (either because it won’t compile or because you can’t satisfy the semantics of both protocols) without designing the protocols together to avoid conflicts.  (I have definitely had to go back and rename/refactor properties on a protocol for this reason… which I couldn’t have done if I didn’t control both protocols).</div></div></div></blockquote><div><br></div></span><div>I understand something of the difficulty of confronting the diamond problem. As I wrote above, I&#39;m inclined to believe that this proposed feature would help solve a real issue. However, the point I&#39;m trying to make is that, on reflection, I have never actually been hampered by the lack of this feature, and so I&#39;d like to continue the discussion to get a fuller sense of just how impactful this proposal would be, both positive and negative.</div><div><br></div><div>It&#39;s true, of course, that if you control at least one of two protocols (you don&#39;t need to control both protocols), it is trivially easy to cause this problem to occur, but as you point out it is also possible to resolve the problem by re-designing the protocol you control. I&#39;m inclined to think (without evidence, admittedly) that re-designing to remove the conflict, where possible, would actually be the superior option in most cases.</div><div><br></div><div>My question was: have you actually run into a scenario that necessitates the feature you propose because you controlled neither conflicting protocol? I think it would strengthen the proposal greatly to have a concrete, uncontrived example.</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><div>Take a look at Eiffel’s ‘rename’ &amp; ’select’ features for similar functionality and use-cases.</div><div><br></div><div>Ultimately, this is a step in the direction of having true mixins.</div><span><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div></div></div></div></div></div></blockquote></span></div></div></blockquote><div><br></div></span><div>Sure, maybe. I couldn&#39;t evaluate that claim. I&#39;m inclined to favor the proposal, but it&#39;d have to stand on its own merits, not as a step to an as-yet undesigned feature.</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><span><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div>   I am fairly certain this affects the ABI though, so I thought I would bring it up now.</div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<br>
If two protocols have methods/properties with the same name, but different signatures, we need a way to distinguish between them when attempting to conform to both.<br>
<br>
        protocol A {<br>
                var x:Int {get set}<br>
        }<br>
<br>
        protocol B {<br>
                var x:Double {get set}<br>
        }<br></blockquote><div><br></div><div>Methods can be overloaded that differ in arguments or return type, so it seems like this problem mainly exists with *properties* that differ in type--am I wrong?</div></div></div></div></div></blockquote><div><br></div></span><div>There is also the case of functions with the same name and signature, but different semantics.  There may be no single implementation which simultaneously satisfies the semantics for both protocols. By renaming one of the functions, we are able to provide separate implementations for each requirement (which allows both protocols to function as intended).</div></div></div></blockquote><div><br></div></span><div>True. However, putting on my critical hat, this seems like we&#39;re stretching to provide support for an anti-pattern. It&#39;d be nice to have an example where one runs into the motivating problem *and* where the proposed feature promotes a _better_ design than is currently possible, rather than making a bad design compile.</div><div><br></div><div>At this point, I&#39;m imagining scenarios where a user is trying to conform a type MyAnimal to both Biped and Quadruped, then worrying that `walk()` has two semantics: something has already gone deeply wrong IMO.</div><div><br></div><div>[Yes, I know there are animals that can sometimes walk on two or four legs. The point here is that the protocols were clearly designed to model animals at a certain level of detail, while it appears that the user writing `MyAnimal` wants to model the animal at a different level of detail than either protocol was designed to handle. You might have specific qualms about this particular hypothetical, but I think you can pick out the general point that there is a much larger problem inherent in the design than the specific problem regarding two colliding method signatures.]</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><div>There may also be functions in different protocols with different names but the same semantics and signature.  This will allow a single implementation to satisfy both protocols without duplication.</div></div></div></blockquote><div><br></div></span><div>This is a poor argument IMO. You can already implement foo() and then have bar() forward to foo() with trivial effort and really minimal boilerplate. It&#39;s an existing solution, and a more general solution because it doesn&#39;t require matching signatures. Also, it&#39;s a better solution IMO because it preserves the notion that a type T : Fooable, Barrable provides the full API guaranteed by Fooable and Barrable.</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><div>Finally, we may want to rename an inherited default implementation to avoid conflicting with another protocol&#39;s default implementation in cases where we don’t want to override it.</div></div></div></blockquote><div><br></div></span><div>Yes, I think this would be handy. I can&#39;t think of an existing way to do this, and I expect it might make a big difference in designing good protocols. So here, I think we have a strong argument.</div><div><br></div><div>Again, though, could we find a concrete example of how this feature would promoter a better design of an actual type and/or protocol?</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><span><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div> One possibility is to allow a struct/class/enum to conform to the protocol while renaming one (or both) of the clashing methods:</div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<br>
        struct C: A,B {<br>
                var x:Int<br>
                var y:Double implements B.x<br>
        }<br>
<br>
The conforming method/property would still have to have the same signature, but could have a different name (and parameter labels).  It would also allow protocol methods which have identical signatures and semantics, but different names to be implemented using the same method (i.e ‘implements D.z &amp; E.w’).<br>
<br>
When something is cast to the protocol (say ‘as B’), then calling the property (e.g. ‘x’) would end up calling the implementation of the renamed property ( ‘y’ in this example) on the conforming type.<br></blockquote><div><br></div><div>Reflecting on this proposed change, it occurs to me that something of value would be lost, and I think that this something is actually rather valuable:</div><div><br></div><div>Today, when I see that a type conforms to (for example) Sequence, I know that certain methods and/or properties exist on that type. Protocol conformance guarantees a certain API, not just certain semantics.</div></div></div></div></div></blockquote><div><br></div></span><div>It isn’t actually lost, however.  When working with it as a Sequence (for example), that API would be intact using the original names.  It is only when working with it as its own type that the renaming would have an effect.</div></div></div></blockquote><div><br></div></span><div>That is not my point. With this proposal, knowing that MyGreatType conforms to Sequence would no longer yield any information as to the MyGreatType API. That is definitely something lost and we should acknowledge that.</div><div><br></div><div>Also, recall that Sequence has Self or associated type requirements. So:</div><div><br></div><div>```</div><div>let m = MyGreatType()</div><div>// There is nothing I can write here to use the Sequence API with `m`, IIUC;</div><div>// however, depending on how this feature is designed, I *might* be able to</div><div>// call a generic function that operates on a type `T : Sequence` and work</div><div>// with `m` that way.</div><div>```</div><span><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><div><span><blockquote type="cite"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div>Perhaps one way to mitigate this loss would be to have any renamed members listed *in the declaration of conformance*, something like this (with some additional bikeshedding):</div><div><br></div><div>```</div><div>struct MyGreatType : Sequence (count =&gt; length) {</div><div>  // MyGreatType conforms to Sequence but renames `count` to `length`</div><div>}</div><div>```</div></div></div></div></blockquote><div><br></div></span><div>Yes, putting it in the conformance declaration is a definite possibility we should consider.</div><span><div><br></div><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
I think we would also want a way to retroactively conform using existing properties/methods in an extension declaring conformance.  Not sure what the best syntax for that would be.  Off the top of my head (though I would love to have something with less cruft):<br>
<br>
        extension D:B {<br>
                @conform(to: B.x, with: D.y)<br>
        }<br>
<br>
or maybe just:<br>
<br>
        extension D:B {<br>
                D.y implements B.x<br>
        }<br></blockquote><div><br></div><div>If renamed members are declared along with protocol conformance, then the syntax for retroactive modeling follows naturally:</div><div><br></div><div>```</div><div>extension D : B (x =&gt; y) { }</div><div>// again, the actual notation here is ugly</div><div>// but the underlying idea, I think, is worth considering</div><div>```</div></div></div></div></div></blockquote><div><br></div></span><div>Yup</div><div><br></div><div>One thing I like about this is that it helps to solve the diamond problem.  ‘x’ could be a default implementation in B which D does not override.  I think this is an important case which my original proposal didn’t address fully.</div><div><br></div><div>We should keep bikeshedding the syntax though...</div></div><br><div>Thanks,</div><div>Jon</div><div><br></div><div><br></div></div></blockquote></span></div><br></div></div>
<br></div></div><span>______________________________<wbr>_________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailma<wbr>n/listinfo/swift-evolution</a><br>
<br></span></blockquote></div><br></div>
</blockquote></div></div></div><br></div></div>
</blockquote></div><br></div>