<div dir="ltr">I figured that sentence was in reference to the methods currently named flatten().<div><br></div><div>The proposal also said that the String-based version of joined(separator:) (which are implemented separately) should have a default separator of &quot;&quot;. There is currently no flatten() for collections of Strings.</div><div><br></div><div><a href="https://github.com/apple/swift/blob/c6e828f761fc30f7ce444431de7da52814f96595/stdlib/public/core/String.swift#L769">https://github.com/apple/swift/blob/c6e828f761fc30f7ce444431de7da52814f96595/stdlib/public/core/String.swift#L769</a><br></div><div><br></div><div>I doubt there would be a performance difference between adding `func joined() { return joined(separator: &quot;&quot;) }` and changing the parameter to `separator: String = &quot;&quot;`.</div><div class="gmail_extra"><br clear="all"><div><div class="gmail_signature"><div dir="ltr"><div>Jacob<br></div></div></div></div>
<br><div class="gmail_quote">On Wed, Jul 27, 2016 at 3:57 PM, Chris Lattner <span dir="ltr">&lt;<a href="mailto:clattner@apple.com" target="_blank">clattner@apple.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="word-wrap:break-word"><br><div><span class="gmail-"><blockquote type="cite"><div>On Jul 27, 2016, at 2:59 PM, Jacob Bandes-Storch &lt;<a href="mailto:jtbandes@gmail.com" target="_blank">jtbandes@gmail.com</a>&gt; wrote:</div><br><div><div dir="ltr">Does the core team have feedback on whether Collection&lt;String&gt;&#39;s joined(separator:) should have a default separator of &quot;&quot;, or another overload with no parameter?</div></div></blockquote><div><br></div></span>&quot;The core team prefers that it remain a distinct overload of joined(separator:) to preserve performance.”  :-)</div><div><br></div><div>Thanks Jacob!</div><span class="gmail-HOEnZb"><font color="#888888"><div><br></div><div>-Chris</div></font></span><span class="gmail-"><div><br><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra">
<br><div class="gmail_quote">On Wed, Jul 27, 2016 at 2:56 PM, Jacob Bandes-Storch <span dir="ltr">&lt;<a href="mailto:jtbandes@gmail.com" target="_blank">jtbandes@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">I&#39;ll get right on it.  Thanks to everyone who provided great feedback during the review!<div><div><div class="gmail_extra">
<br><div class="gmail_quote">On Wed, Jul 27, 2016 at 2:53 PM, Chris Lattner via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Proposal Link: <a href="https://github.com/apple/swift-evolution/blob/master/proposals/0133-rename-flatten-to-joined.md" rel="noreferrer" target="_blank">https://github.com/apple/swift-evolution/blob/master/proposals/0133-rename-flatten-to-joined.md</a><br>
<br>
The review of &quot;SE-0133: Rename flatten() to joined()&quot; ran from Active review July 24…26. The proposal has been *accepted*.<br>
<br>
This proposal had significant positive community feedback for aligning common operation names, but raised questions about whether ‘flatten’ was term of art, and what it would mean for related operations like ‘flatMap’.  The core team discussed both sides of this debate, and decided it is best to rename ‘flatten’ to ‘joined’, but keep ‘flatMap’ as it is, to preserve its term of art.  The core team prefers that it remain a distinct overload of joined(separator:) to preserve performance.  It also requests that the returned collection types (FlattenCollection and friends) be left as-is for now, since they are not names commonly directly referenced, and we’d like to keep the change minimal.<br>
<br>
Thank you to Jacob Bandes-Storch for driving this discussion forward!  Time is short, we’d appreciate it if someone could implement this ASAP.<br>
<br>
-Chris Lattner<br>
Review Manager<br>
<br>
<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div><br></div></div></div></div>
</blockquote></div><br></div></div>
</div></blockquote></div><br></span></div></blockquote></div><br></div></div>