<html><head><style>
body {
        font-family: "Helvetica Neue", Helvetica, Arial, sans-serif;
        padding:1em;
        margin:auto;
        background:#fefefe;
}

h1, h2, h3, h4, h5, h6 {
        font-weight: bold;
}

h1 {
        color: #000000;
        font-size: 28pt;
}

h2 {
        border-bottom: 1px solid #CCCCCC;
        color: #000000;
        font-size: 24px;
}

h3 {
        font-size: 18px;
}

h4 {
        font-size: 16px;
}

h5 {
        font-size: 14px;
}

h6 {
        color: #777777;
        background-color: inherit;
        font-size: 14px;
}

hr {
        height: 0.2em;
        border: 0;
        color: #CCCCCC;
        background-color: #CCCCCC;
    display: inherit;
}

p, blockquote, ul, ol, dl, li, table, pre {
        margin: 15px 0;
}

a, a:visited {
        color: #4183C4;
        background-color: inherit;
        text-decoration: none;
}

#message {
        border-radius: 6px;
        border: 1px solid #ccc;
        display:block;
        width:100%;
        height:60px;
        margin:6px 0px;
}

button, #ws {
        font-size: 12 pt;
        padding: 4px 6px;
        border-radius: 5px;
        border: 1px solid #bbb;
        background-color: #eee;
}

code, pre, #ws, #message {
        font-family: Monaco;
        font-size: 10pt;
        border-radius: 3px;
        background-color: #F8F8F8;
        color: inherit;
}

code {
        border: 1px solid #EAEAEA;
        margin: 0 2px;
        padding: 0 5px;
}

pre {
        border: 1px solid #CCCCCC;
        overflow: auto;
        padding: 4px 8px;
}

pre > code {
        border: 0;
        margin: 0;
        padding: 0;
}

#ws { background-color: #f8f8f8; }


.bloop_markdown table {
border-collapse: collapse;  
font-family: Helvetica, arial, freesans, clean, sans-serif;  
color: rgb(51, 51, 51);  
font-size: 15px; line-height: 25px;
padding: 0; }

.bloop_markdown table tr {
border-top: 1px solid #cccccc;
background-color: white;
margin: 0;
padding: 0; }
     
.bloop_markdown table tr:nth-child(2n) {
background-color: #f8f8f8; }

.bloop_markdown table tr th {
font-weight: bold;
border: 1px solid #cccccc;
margin: 0;
padding: 6px 13px; }

.bloop_markdown table tr td {
border: 1px solid #cccccc;
margin: 0;
padding: 6px 13px; }

.bloop_markdown table tr th :first-child, table tr td :first-child {
margin-top: 0; }

.bloop_markdown table tr th :last-child, table tr td :last-child {
margin-bottom: 0; }

.bloop_markdown blockquote{
  border-left: 4px solid #dddddd;
  padding: 0 15px;
  color: #777777; }
  blockquote > :first-child {
    margin-top: 0; }
  blockquote > :last-child {
    margin-bottom: 0; }

code, pre, #ws, #message {
    word-break: normal;
    word-wrap: normal;
}

hr {
    display: inherit;
}

.bloop_markdown :first-child {
    -webkit-margin-before: 0;
}

code, pre, #ws, #message {
    font-family: Menlo, Consolas, Liberation Mono, Courier, monospace;
}


.send { color:#77bb77; }
.server { color:#7799bb; }
.error { color:#AA0000; }</style></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div class="bloop_markdown"><p>Currently I could implement the whole type like this:</p>

<pre><code class="swift">public struct Type&lt;T&gt; : Hashable, CustomStringConvertible, CustomDebugStringConvertible {
     
    // Anyone knows a better name?
    public let sealed: T.Type = T.self
     
    public let hashValue: Int = ObjectIdentifier(T.self).hashValue
     
    // Inspired by SE-0101
    public static var size: Int { return sizeof(T.self) }
    public static var stride: Int { return strideof(T.self) }
    public static var alignment: Int { return alignof(T.self) }
     
    public var size: Int { return Type&lt;T&gt;.size }
    public var stride: Int { return Type&lt;T&gt;.stride }
    public var alignment: Int { return Type&lt;T&gt;.alignment }
     
    public var description: String { return "Type&lt;\(self.sealed)&gt;" }
     
    public var debugDescription: String {
        return "&lt;" + self.description + " size: \(self.size) stride: \(self.stride) alignment: \(self.alignment)&gt;"
    }
}

public func ==&lt;T, U&gt;(lhs: Type&lt;T&gt;, rhs: Type&lt;U&gt;) -&gt; Bool {
     
    return lhs.hashValue == rhs.hashValue
}
</code></pre>

<p>I also added static computed properties to access the the memory layout without any initialization.</p>

<p><code>Type&lt;Int&gt;.size</code> reads really great to me.</p>

<p>I’m curious about the feedback from the Swift community. :)</p>

<p>PS: All my replies are markdown formatted. If anyone can’t read them, here is a formatted gist: <a href="https://gist.github.com/DevAndArtist/c35284ac12806c13eff302d1cf347ac8">https://gist.github.com/DevAndArtist/c35284ac12806c13eff302d1cf347ac8</a></p>

<p></p></div><div class="bloop_original_html"><style>body{font-family:Helvetica,Arial;font-size:13px}</style><div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;"><br></div> <br> <div id="bloop_sign_1468060314057022976" class="bloop_sign"><div style="font-family:helvetica,arial;font-size:13px">--&nbsp;<br>Adrian Zubarev<br>Sent with Airmail</div></div> <br><p class="airmail_on">Am 9. Juli 2016 um 12:03:39, Adrian Zubarev (<a href="mailto:adrian.zubarev@devandartist.com">adrian.zubarev@devandartist.com</a>) schrieb:</p> <blockquote type="cite" class="clean_bq"><span><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><div></div><div>




<title></title>



<div class="bloop_markdown">
<p>Correcting the function from the very first post:</p>
<pre><code class="swift">public func ==&lt;T, U&gt;(lhs: Type&lt;T&gt;, rhs: Type&lt;U&gt;) -&gt; Bool {
       
    return lhs.hashValue == rhs.hashValue
}
</code></pre></div>
<div class="bloop_original_html">

<div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">
<br></div>
<br>
<div id="bloop_sign_1468058593060718080" class="bloop_sign">
<div style="font-family:helvetica,arial;font-size:13px">
--&nbsp;<br>
Adrian Zubarev<br>
Sent with Airmail</div>
</div>
<br>
<p class="airmail_on">Am 9. Juli 2016 um 11:55:00, Adrian Zubarev
(<a href="mailto:adrian.zubarev@devandartist.com">adrian.zubarev@devandartist.com</a>)
schrieb:</p>
<blockquote type="cite" class="clean_bq">
<div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
<div>
<div class="bloop_markdown">
<p><span>Here are a few more thoughts on solving a few problems
with dropped <code>.self</code> in mind:</span></p>
<ol>
<li>
<p><span><code>Type&lt;SomeType&gt;</code> cannot become
<code>Type&lt;Type&lt;SomeType&gt;&gt;</code> to prevent infinite
recursion.</span></p>
</li>
<li>
<p><span>Any other type without the short form for initializer
<code>SomeType(...)</code> or explicit access to static members or
initializer like <code>SomeType.init(...)</code> or
<code>SomeType.staticMember</code> will be automatically become
<code>Type&lt;SomeType&gt;</code> - if it’s not part of an array or
dictionary shorthand syntax.</span></p>
</li>
<li>
<p><span>For array and dictionary shorthand syntax any type (except
other nested array and dictionary shorthand types) does not follow
the second rule from above (dropped <code>.self</code> in
mind):</span></p>
<ul>
<li><span><code>[SomeType]()</code> equals
<code>Array&lt;SomeType&gt;()</code></span></li>
<li><span><code>[Type&lt;SomeType&gt;]()</code> equals
<code>Array&lt;Type&lt;SomeType&gt;&gt;()</code></span></li>
<li><span><code>[SomeKeyType: SomeValueType]()</code> equals
<code>Dictionary&lt;SomeKeyType,
SomeValueType&gt;()</code></span></li>
<li><span><code>[Type&lt;SomeKeyType&gt;:
Type&lt;SomeValueType&gt;]()</code> equals
<code>Dictionary&lt;Type&lt;SomeKeyType&gt;,
Type&lt;SomeValueType&gt;&gt;()</code></span></li>
</ul>
</li>
</ol>
<p><span>We also could extend <code>Type&lt;T&gt;</code> to provide
more useful informations:</span></p>
<pre><span><code class="swift">public struct Type&lt;T&gt; : Hashable, CustomStringConvertible, CustomDebugStringConvertible {
        
    // Anyone knows a better name?
    public let sealed: T.Type
        
    public var hashValue: Int { /* implement */ }
       
    // Inspired by SE-0101
    public var size: Int { /* implement */ }
    public var stride: Int { /* implement */ }
    public var alignment: Int { /* implement */ }
       
    public var description: String { /* implement */ }
       
    public var debugDescription: String { /* implement */ }
        
    public init() { /* implement */ }
}
</code></span></pre></div>
<div class="bloop_original_html">
<div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">
<span><br></span></div>
<span><br></span>
<div id="bloop_sign_1468055291563095040" class="bloop_sign">
<div style="font-family:helvetica,arial;font-size:13px">
<span>--&nbsp;<br>
Adrian Zubarev<br>
Sent with Airmail</span></div>
</div>
<span><br></span>
<p class="airmail_on"><span>Am 8. Juli 2016 um 22:06:30, Adrian
Zubarev (<a href="mailto:adrian.zubarev@devandartist.com">adrian.zubarev@devandartist.com</a>)
schrieb:</span></p>
<blockquote type="cite" class="clean_bq">
<div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
<div>
<div class="bloop_markdown">
<p><span><span>Hello Swift community, before Swift 3 drops I’d like
to discuss if it is reasonable to consider to create a standalone
type to drop/seal the <code>T.Type</code> magic?</span></span></p>
<p><span>However this change does not play well with the proposal
of dropping the <code>.self</code> compiler magic.</span></p>
<p><span>Some bikeshedding:</span></p>
<pre><span><code class="swift">public struct Type&lt;T&gt; : Hashable {
        
    // Seal the `.Type` magic into this standalone type.
    // Disallow `.Type` usage elsewhere
        
    public let sealed: T.Type
        
    public var hashValue: Int { /* implement somehow */ }
        
    public init() {
            
        // Or do it somehow different for the sake of dropping `.self` magic
        self.sealed = T.self
    }
}

public func ==&lt;T&gt;(lhs: Type&lt;T&gt;, rhs: Type&lt;T&gt;) -&gt; Bool {
        
    return lhs.hashValue == rhs.hashValue
}
</code></span></pre>
<p><span>Downside of this approach is the accessibility of the
<code>.Type</code> instance:</span></p>
<pre><span><code class="swift">protocol Initializable {
    init()
}

func foo&lt;T : Initializable&gt;(type: Type&lt;T&gt;) -&gt; T {
        
    // It would be nice if we could use `type.init()` instead, but than we
    // would need more compiler magic :/
    return type.sealed.init()
}
</code></span></pre>
<p><span>I couldn’t come up with a better name than
<code>sealed</code>, if anyone has a better idea feel free to share
your thoughts.</span></p>
<p><span>Remember this is a discussion and not (yet) a detailed
proposal, where everyone can provide feedback and bikeshedding for
a better design.</span></p>
</div>
<div class="bloop_original_html">
<div id="bloop_customfont" style="font-family:Helvetica,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;">
<span><br></span></div>
<span><br></span>
<div id="bloop_sign_1468001575976519168" class="bloop_sign">
<div style="font-family:helvetica,arial;font-size:13px">
<span>--&nbsp;<br>
Adrian Zubarev<br>
Sent with Airmail</span></div>
</div>
</div>
<div class="bloop_markdown"></div>
</div>
</div>
</blockquote>
</div>
<div class="bloop_markdown"></div>
</div>
</div>
</blockquote>
</div>
<div class="bloop_markdown"></div>


</div></div></span></blockquote></div><div class="bloop_markdown"><p></p></div></body></html>