Being consistent with existing convention is good; I also agree it happens to make perfect sense anyway.<br><br><div class="gmail_quote"><div dir="ltr">On Sun, Jul 3, 2016 at 03:18 Andrew Trick via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><br><div><blockquote type="cite"><div>On Jul 2, 2016, at 8:10 PM, Brent Royal-Gordon via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt; wrote:</div><br><div><span style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;float:none;display:inline!important">I have a pile of naming quibbles; rather than describe them all in prose (which turned into a mess), I&#39;ve annotated parts of the &quot;Full UnsafeRawPointer API&quot; section in a gist: &lt;</span><a href="https://gist.github.com/brentdax/8f4ed4decafc1d18c4441092baa13cfe" style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px" target="_blank">https://gist.github.com/brentdax/8f4ed4decafc1d18c4441092baa13cfe</a><span style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;float:none;display:inline!important">&gt;.</span><br style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px"><br style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px"></div></blockquote></div><div><br></div>Let&#39;s bikeshed this easy one now... I’m curious what others think:<br><div><br>  // In general, I think you &quot;initialize to&quot; a value, not <br>  // &quot;initialize with&quot; a value. &quot;with&quot; is needlessly vacuous.<br>  // <br>  // func initialize&lt;T&gt;(_: T.Type, with: T, count: Int = 1)<br>  //   -&gt; UnsafeMutablePointer&lt;T&gt;<br>  func initialize&lt;T&gt;(_: T.Type, to: T, count: Int = 1)<br>    -&gt; UnsafeMutablePointer&lt;T&gt;<br><br></div><div>`initialize` was recently renamed to `initialized(with:)`.</div><div><br></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(175,173,36);background-color:rgb(0,0,0)"><span>commit d96b051d28b6042adcc8b8692a918abddf211aec</span></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0)"><span>Author: Dave Abrahams &lt;<a href="mailto:dabrahams@apple.com" target="_blank">dabrahams@apple.com</a>&gt;</span></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0)"><span>Date:   Tue Feb 23 15:12:24 2016 -0800</span></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0);min-height:11px"><span></span><br></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0)"><span>    stdlib: initializePointee(_) =&gt; initialize(with:)</span></div><p style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0);min-height:11px"><span>    </span><br></p><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0)"><span>    Tacking &quot;Pointee&quot; on just for unary operations (and especially</span></div><div style="margin:0px;font-size:10px;line-height:normal;font-family:Menlo;color:rgb(245,245,245);background-color:rgb(0,0,0)"><span>    operations with an optional count) created inconsistency.</span></div><div><br></div><div>So Swift 3 users have already migrated to this “better” name.</div><div><br></div><div>I agree that initialize(to:) is consistent with the language we use for assigning values. But grammatically, I think initialize(with:) also makes perfect sense and is just as common.</div><div><br></div><div>In general, if there’s controversy, I’ll stick with the existing conventions because there’s already enough to debate in this proposal.</div><div><br></div><div>-Andy</div></div>_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>