And from the WWDC Platforms SOTU: &quot;Swift is super simple and approachable.... It&#39;s great as a first language. And in fact, we think this is so important that when we designed Swift this was an explicit design goal.&quot;<br><br>I would be absolutely against adding any more sugar to the for loop. In that sense, `where` sets a terrible example that certain features of sequences deserve contextual sugar. (And before someone points it out again, I&#39;ve already argued why `for...in` holds its own weight, namely difficulty of writing a correct `while` replacement and progressive disclosure to the learner so that the concept of iterators can be learned afterwards.)<br><br>In short, I would very much be opposed to adding keywords &quot;for fun.&quot;<br><br><div class="gmail_quote"><div dir="ltr">On Tue, Jun 14, 2016 at 11:18 AM Vladimir.S via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">FWIW I don&#39;t think we need all &quot;4&quot;, just like we don&#39;t need `unless` as a<br>
pair to current `if` or `until` as a pair for current `while` loop.<br>
<br>
I.e. we have &quot;continue&quot; with current `where`, and you can use boolean<br>
inversion `!`. As for &quot;break&quot;(while) - my opinion the for-in loop will be<br>
more powerful and adds fun for coding (from wwdc keynote - &quot;Swift is a<br>
powerful language.. writing Swift code is *fun*...&quot; my opinion: using<br>
guard-continue or guard-break is *not* fun ).<br>
<br>
So in your words, it is better add *one* then remove *one*.<br>
<br>
The only question I&#39;m not sure about if we should keep &#39;where&#39; and &#39;while&#39;<br>
keywords for these features, or rename them. For me it&#39;s OK to have &#39;where&#39;<br>
and &#39;while&#39; but probably I&#39;ll support another more clear keywords.<br>
<br>
On 14.06.2016 18:01, Erica Sadun via swift-evolution wrote:<br>
&gt;<br>
&gt;&gt; On Jun 14, 2016, at 7:50 AM, plx via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt; wrote:<br>
&gt;&gt; For those particular keywords, I’d prefer having them (or equivalents). I’m not sure if I’d prefer having *all* of them—`where/unless` and `while/until`—or just one from each “pair”…I could go either way.<br>
&gt;<br>
&gt; In the proposal, my recommendations for including all 4 are:<br>
&gt;<br>
&gt; break: while / until<br>
&gt; continue: if (formerly `where`) / unless<br>
&gt;<br>
&gt; As the thread has had sufficient redundancy, I&#39;ll refrain from making my case again for why I think it&#39;s better to remove the one than add the three.<br>
&gt;<br>
&gt; -- E<br>
&gt;<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; swift-evolution mailing list<br>
&gt; <a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
&gt; <a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
&gt;<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>