<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Jun 10, 2016 at 3:15 PM, Thorsten Seitz via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word">-1<div><span class=""><br><div><blockquote type="cite"><div>Am 10.06.2016 um 21:10 schrieb Brent Royal-Gordon via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;:</div><br><div><span style="font-family:Helvetica;font-size:12px;font-style:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;float:none;display:inline!important">if case .some(let Point.cartesian(x, y)) where x &lt; y = json[&quot;rect&quot;]?[&quot;origin&quot;].flatMap(.init(rawValue:)) { … }</span></div></blockquote><br></div></span><div>This: `where x &lt; y = json[…]` is *very* unreadable and probably unparseable as it is missing a delimiter between the boolean expression and the expression behind the assignment operator. And I do not count the assignment operator as a sufficient delimiter.</div></div></div></blockquote><div><br></div><div>Agreed. Unless this readability issue can be solved, I&#39;m concerned about this particular reshuffling.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div><div><br></div><div>I’ll give the following counterargument against this shuffling around of `where` or trying to eliminate it:</div><div><br></div><div><span style="white-space:pre-wrap">        </span>if case .some(let x) = someExpression where x &gt; 0</div><div><br></div><div><span style="white-space:pre-wrap">        </span>for x in xs where x &gt; 0</div><div><br></div><div>These are actually very consistent in their grammar when you look at it like follows:</div><div><br></div><div><span style="white-space:pre-wrap">        </span>&lt;target&gt; &lt;assignment op&gt; &lt;source&gt; where &lt;condition&gt;</div><div><br></div><div><br></div><div><span style="white-space:pre-wrap">        </span>if case .some(let x) = someExpression where x &gt; 0</div><div><br></div><div><span style="white-space:pre-wrap">        </span>target: `case .some(let x)`</div><div><span style="white-space:pre-wrap">        </span>assignment op: `=`</div><div><span style="white-space:pre-wrap">        </span>source: `someExpression`</div><div><span style="white-space:pre-wrap">        </span>condition: `x &gt; 0`</div><div><br></div><div><br></div><div><div><span style="white-space:pre-wrap">        </span>for x in xs where x &gt; 0</div><div><br></div><div><div><span style="white-space:pre-wrap">        </span>target: `x`</div><div><span style="white-space:pre-wrap">        </span>assignment op: `in`</div><div><span style="white-space:pre-wrap">        </span>source: `xs`</div><div><span style="white-space:pre-wrap">        </span>condition: `x &gt; 0`</div></div><div><br></div><div><br></div><div>That is I’m arguing the `where` grammar is already quite regular and should not be changed. And yes, I’d like to have `where` back in `case`. And `let`.</div></div></div></div></blockquote><div><br></div><div>The inconsistency argument is that this grammar is inconsistent with usage when switching over cases, etc., not that it&#39;s inconsistent with usage in `if`.</div><div><br></div><div>Principally, though, the problem is that `where` leaves implied but unanswered the question of &quot;what happens where not?&quot; For an `if` statement the answer is inherent to the word &quot;if,&quot; but because it is inherent, it becomes redundant and can be replaced with a comma. Likewise `while`. For a `for` loop, `where` cannot be replaced with a comma because it is not implied by the word `for`; but because it is not redundant, it is also not inherent in the meaning of the word &quot;where.&quot;</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div><div><div><br></div></div><div>-Thorsten</div><br></div></div><br>_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
<br></blockquote></div><br></div></div>