<div dir="ltr">This was one of the first and most commonly suggested ideas, when the Swift Evolution mailing list first started.<div><a href="https://lists.swift.org/pipermail/swift-evolution/Week-of-Mon-20151214/003546.html">Chris Lattner sums it up</a> in one of those threads:</div><div><br></div><div>&gt; This is commonly requested - the problem is that while it does help reduce boilerplate, it runs counter to the goal of improving clarity.</div><div><br></div><div>— Johan</div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, May 17, 2016 at 3:43 PM, Vladimir.S via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">It is common to shadow optional value name with unwrapped value with same name:<br>
<br>
if let someGoodValue = someGoodValue {...}<br>
<br>
What if we&#39;ll have a syntax to not repeat the variable name to achieve the same target:<br>
<br>
if let someGoodValue! {...}<br>
<br>
What do you think?<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div><br></div></div>