<div dir="ltr">Alright, so as you are also okay with `clamping` I will update the proposal with it. :-)<div><br></div><div>- Luis<br><div class="gmail_extra"><div><div><div dir="ltr"><div><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"></div></div></div></div></div></div></div></div></div></div>
<br><div class="gmail_quote">On Fri, May 13, 2016 at 3:00 PM, Vladimir.S <span dir="ltr">&lt;<a href="mailto:svabox@gmail.com" target="_blank">svabox@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Personally I don&#39;t feel like `flat` is better. Especially if there is `clamping` in Range for the same purpose. Then we should not re-invent the wheel.<span><br>
<br>
On 13.05.2016 16:09, Luis Henrique B. Sousa wrote:<br>
</span><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span>
Perhaps another word that could fit in the first case<br>
(truncate/bounded/within/clamping) is `flat`. Along the same lines of the<br>
`flatMap` which returns only non-nil values, here we have an empty array<br>
instead of nil when the range doesn&#39;t apply at all.<br>
<br>
let array = [1,2,3]<br>
<br>
array[flat: 0..&lt;10] // [1,2,3]<br>
array[checking: 0..&lt;10] // nil<br>
<br>
I&#39;m still not sure if `clamping` is the right word. What do you think?<br>
<br>
- Luis<br>
<br>
On Thu, May 12, 2016 at 7:25 AM, Brent Royal-Gordon &lt;<a href="mailto:brent@architechies.com" target="_blank">brent@architechies.com</a><br></span><span>
&lt;mailto:<a href="mailto:brent@architechies.com" target="_blank">brent@architechies.com</a>&gt;&gt; wrote:<br>
<br>
    &gt; It sounds good, thanks for you suggestions @Vladimir, @Patrick and @Brent.<br>
    &gt;<br>
    &gt; I&#39;ve just updated the proposal:<br>
    &gt; <a href="https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design" rel="noreferrer" target="_blank">https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design</a><br>
    &gt;<br>
    &gt; - Luis<br>
<br>
    Hmm. If you&#39;re going with `checking` for one of them, perhaps the other<br>
    should be `clamping` (for the analogous method on `Range`, which you<br>
    might want to use in the implementation of that subscript). That would<br>
    create a nicely matched pair:<br>
<br>
            array[checking: 0..&lt;10]<br>
            array[clamping: 0..&lt;10]<br>
<br>
    --<br>
    Brent Royal-Gordon<br>
    Architechies<br>
<br>
<br>
</span></blockquote>
</blockquote></div><br></div></div></div>