<div dir="ltr"><div class="gmail_extra">I agree with your parenthesis, but it might not be a valid argument if we consider that &quot;clamp&quot; is already a word used <a href="https://developer.apple.com/library/watchos/documentation/Swift/Reference/Swift_HalfOpenInterval_Structure/index.html#//apple_ref/swift/structm/HalfOpenInterval/s:FVs16HalfOpenInterval5clampFGS_x_GS_x_">in the standard library</a>.</div><div class="gmail_extra">(but I have to say that also as a non-native speaker &quot;within&quot; was way more clear to me at first sight... 8-) )</div><div class="gmail_extra"><div><div class="gmail_signature"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr" style="font-size:small"><br></div><div dir="ltr"></div>- Luis</div></div></div></div></div></div></div></div></div>
<br><div class="gmail_quote">On Thu, May 12, 2016 at 12:08 PM, Vladimir.S <span dir="ltr">&lt;<a href="mailto:svabox@gmail.com" target="_blank">svabox@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex">If there is a method with such name in Range(with equal meaning) - then it seems like `clamping` will be the best solution here.<br>
(as non-native speaker I don&#39;t feel this word is often used especially in software development, but.. it seems like anyone who is writing in Swift must be strong native English speaker/writer :-P I also mean all these naming conversions, verb/noun, -ing/-ed/-able etc ;-) )<span class=""><br>
<br>
On 12.05.2016 12:56, Luis Henrique B. Sousa wrote:<br>
</span><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex"><span class="">
Yes, it would really be more consistent. &quot;within&quot; sounds great to me as<br>
well, but I don&#39;t know if there is a naming convention for it.<br>
I am okay to change our proposal to have those labels as two verbs -<br>
instead of a preposition and a verb - as suggested by @Brent.<br>
<br>
More opinions?<br>
<br>
- Luis<br>
<br>
On Thu, May 12, 2016 at 7:25 AM, Brent Royal-Gordon &lt;<a href="mailto:brent@architechies.com" target="_blank">brent@architechies.com</a><br></span><span class="">
&lt;mailto:<a href="mailto:brent@architechies.com" target="_blank">brent@architechies.com</a>&gt;&gt; wrote:<br>
<br>
    &gt; It sounds good, thanks for you suggestions @Vladimir, @Patrick and @Brent.<br>
    &gt;<br>
    &gt; I&#39;ve just updated the proposal:<br>
    &gt; <a href="https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design" rel="noreferrer" target="_blank">https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design</a><br>
    &gt;<br>
    &gt; - Luis<br>
<br>
    Hmm. If you&#39;re going with `checking` for one of them, perhaps the other<br>
    should be `clamping` (for the analogous method on `Range`, which you<br>
    might want to use in the implementation of that subscript). That would<br>
    create a nicely matched pair:<br>
<br>
            array[checking: 0..&lt;10]<br>
            array[clamping: 0..&lt;10]<br>
<br>
    --<br>
    Brent Royal-Gordon<br>
    Architechies<br>
<br>
<br>
</span></blockquote>
</blockquote></div><br></div></div>