<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Mon, Apr 25, 2016 at 1:32 PM, Stephen Canon via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex"><span><br>
&gt; On Apr 23, 2016, at 8:53 PM, Brent Royal-Gordon via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt; wrote:</span><span><br>
&gt;&gt;  func isEqual(to other: Self) -&gt; Bool<br>
&gt;&gt;  func isLess(than other: Self) -&gt; Bool<br>
&gt;&gt;  func isLessThanOrEqual(to other: Self) -&gt; Bool<br>
&gt;<br>
&gt; I&#39;m still not sure why these are methods instead of operators.<br>
&gt;<br>
&gt; (I also share others&#39; concern about the argument label on `isLessThanOrEqual`.)<br>
<br>
</span>There’s lots of concern, and very few suggestions of anything better.  The only thing that seems workable is maybe `isLessThanOrEqualTo(_:)`, which is inconsistent with the other comparisons, but maybe that’s the right thing to do anyway.<br></blockquote><div><br></div><div>My vote is with using operators, and perhaps actually introducing `&lt;=&gt;` for total order as suggested elsewhere. Why invent method names for standard operators?</div></div></div></div>