<div dir="ltr">I think `prefix -` works for `negated` (non-mutating form) but not `negate` (mutating form). IE `-=` is the mutating form of `infix -` and there is no equivalent in C-like languages for `negated` :(</div><div class="gmail_extra"><br clear="all"><div><div class="gmail_signature"> -- Howard.<br></div></div>
<br><div class="gmail_quote">On 19 April 2016 at 08:28, <span dir="ltr"><<a href="mailto:davesweeris@mac.com" target="_blank">davesweeris@mac.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div><blockquote type="cite"><div>On Apr 16, 2016, at 6:12 PM, Howard Lovatt via swift-evolution <<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>> wrote:</div><br><div>For the Arithmetic protocol how about changing it to:<div><br></div><div> protocol Arithmetic {</div><div> func + (lhs: Self, rhs: Self) -> Self</div><div><font size="2"><span style="background-color:rgba(255,255,255,0)"> mutating func += (rhs: Self) -> Self</span></font></div><div><font size="2"><span> ...</span></font></div><div><font size="2"><span> }</span></font></div><div><font size="2"><span><br></span></font></div><div><font size="2"><span>That way naming issues are largely avoided, except for `mutating func negate()` which has no operator and would therefore have to be a normal, non-operator, <span></span>func. <br></span></font></div></div></blockquote></div>“prefix -" works for negate, at least off the top of my head.<div><br></div><div>I think.<br><div><br></div><div>- Dave Sweeris</div></div></div></blockquote></div><br></div>