Ok. Is it final decision? Can I start working on it?<br><div class="gmail_quote"><div dir="ltr">On Sun, 10 Apr 2016 at 23:07, Howard Lovatt via swift-evolution <<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Do it to them all: flatMapped, unioned, etc.<br><br>On Monday, 11 April 2016, Dave Abrahams via swift-evolution <<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
on Fri Apr 08 2016, Brent Royal-Gordon <<a>swift-evolution@swift.org</a>> wrote:<br>
<br>
>> The 'flatten()' method didn't get the Swift 3 API renaming treatment<br>
>> it should have, to go along with reversed, sorted, joined, etc.<br>
>> As I see Dmitri Gribenko already agree with it but we still have to<br>
>> discuss it here. So what do you think?<br>
><br>
> I'm in favor.<br>
><br>
> Though all of these things are terms of art, not all terms of art are created equal. For instance:<br>
><br>
> * `map` is supported by virtually any language which have any of these<br>
> higher-order functions, and to my knowledge the name `map` is<br>
> universally used.<br>
> * `reduce` is not quite as universally supported, but it's still very<br>
> common, and most (but not quite all) languages with higher-order<br>
> functions support it.<br>
> * `filter` is very widely supported, but the *name* `filter` is not<br>
> quite so consistent. Ruby, for instance, calls it `select`, Perl calls<br>
> it `grep`, etc.<br>
> * `takeWhile` lies on the other end of the spectrum, being very narrowly supported.<br>
><br>
> In my opinion, it would be a really bad idea to rename `map` or<br>
> `reduce`; `filter` is probably a bad idea but not terrible; but we<br>
> should feel relatively free to rename `takeWhile`.<br>
><br>
> `flatten` is nowhere near as weak a term of art as `takeWhile`, but I<br>
> think it still falls towards that end of the spectrum. We shouldn't<br>
> worry too much about changing it. `map`, `reduce`, and `filter` are<br>
> much stronger terms, and we should be more cautious about changing<br>
> them.<br>
<br>
The problem is flatMap. The semantics of map, flatMap, and flatten are<br>
inextricably linked. IMO it would be weird to do this to one or two of<br>
these names and not to all of them.<br>
<br>
--<br>
Dave<br>
<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a>swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote><br><br>-- <br>-- Howard.<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>