<html><head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head><body dir="auto"><div></div><div>Good point. That would obviously restrict the choice for naming the methods in such a protocol, but since we are talking about new protocols that would not be an impediment. It might result in non-optimal method names, of course.</div><div><br></div><div>-Thorsten&nbsp;</div><div><br>Am 31.03.2016 um 18:37 schrieb Rob Mayoff via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt;:<br><br></div><blockquote type="cite"><div><div dir="ltr"><div class="gmail_extra">On Thu, Mar 31, 2016 at 10:56 AM, Thorsten Seitz via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br></div><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div style="word-wrap:break-word"><div style="margin:0px;font-size:13px;line-height:normal;font-family:Menlo;color:rgb(131,148,150)"><div style="margin:0px;line-height:normal;min-height:15px"><br></div><div style="margin:0px;line-height:normal"><span style="color:rgb(133,153,1)">protocol</span><span> UIGestureRecognizerDelegate {</span></div><div style="margin:0px;line-height:normal"><span>&nbsp; &nbsp; </span><span style="color:rgb(133,153,1)">var</span><span> gestureRecognizerShouldBegin: ((gestureRecognizer: </span><span style="color:rgb(181,137,1)">UIGestureRecognizer</span><span>) -&gt; </span><span style="color:rgb(181,137,1)">Bool</span><span>)? { </span><span style="color:rgb(133,153,1)">get</span><span> }</span></div><div style="margin:0px;line-height:normal"><span>}</span></div></div></div></blockquote><div><br></div><div>UIGestureRecognizerDelegate has five methods that are "named" gestureRecognizer:</div><div><br></div><div>







<p class=""></p><ul><li><span class="">gestureRecognizer(_:</span><span class="">shouldRecognizeSimultaneouslyWithGestureRecognizer:</span><span class="">)</span><br></li><li><span class="">gestureRecognizer(_:</span><span class="">shouldRequireFailureOfGestureRecognizer:)</span><br></li><li><span class="">gestureRecognizer(_:</span><span class="">shouldBeRequiredToFailByGestureRecognizer:)</span><br></li><li><span class="">gestureRecognizer(_:</span><span class="">shouldReceiveTouch:</span><span class="">)</span><br></li><li><span class="">gestureRecognizer(_:</span><span class="">shouldReceivePress:</span><span class="">)</span><br></li></ul><p></p>


</div><div>You can only have a single property named "gestureRecognizer", so you either have to come up with other names for these, or change the language to allow closure-typed properties to have multipart names.</div><div><br></div><div>This problem has been noted before, for example here:&nbsp;<a href="http://article.gmane.org/gmane.comp.lang.swift.evolution/8707/">http://article.gmane.org/gmane.comp.lang.swift.evolution/8707/</a></div><div><br></div></div></div></div>
</div></blockquote><blockquote type="cite"><div><span>_______________________________________________</span><br><span>swift-evolution mailing list</span><br><span><a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a></span><br><span><a href="https://lists.swift.org/mailman/listinfo/swift-evolution">https://lists.swift.org/mailman/listinfo/swift-evolution</a></span><br></div></blockquote></body></html>