<div style="white-space:pre-wrap">It looks like people finished the discussion for the best access level names. How should I update the proposal?</div><br><div class="gmail_quote"><div dir="ltr">On Mon, Mar 14, 2016 at 8:18 PM Chris Lattner via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Per Doug’s email, the core team agrees we should make a change here, but would like some bikeshedding to happen on the replacement name for private.<br>
<br>
To summarize the place we’d like to end up:<br>
<br>
- “public” -&gt; symbol visible outside the current module.<br>
- “internal” -&gt; symbol visible within the current module.<br>
- unknown -&gt; symbol visible within the current file.<br>
- “private” -&gt; symbol visible within the current declaration (class, extension, etc).<br>
<br>
The rationale here is that this aligns Swift with common art seen in other languages, and that many people using private today don’t *want* visibility out of their current declaration.  It also encourages “extension oriented programming”, at least it will when some of the other restrictions on extensions are lifted.  We discussed dropping the third one entirely, but think it *is* a useful and important level of access control, and when/if we ever get the ability to write unit tests inside of the file that defines the functionality, they will be a nicer solution to @testable.<br>
<br>
The thing we need to know is what the spelling should be for the third one.  Off hand, perhaps:<br>
<br>
fileprivate<br>
private(file)<br>
internal(file)<br>
fileaccessible<br>
etc<br>
<br>
Some other thoughts on the choice:<br>
- this will be a declaration modifier, so it will not “burn” a keyword.<br>
- if will be a uniquely Swift thing, so there is virtue in it being a googlable keyword.<br>
<br>
Thoughts appreciated.<br>
<br>
-Chris<br>
<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>