<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">The functionality of ‘guard’ is great and this proposal has nothing to do with changing that. The only suggestion is that the word ‘ensure’ would better communicate what a ‘guard’ statement does to those encountering it for the first time and would make code more readable in general.<div class=""><br class=""></div><div class="">Example:</div><div class=""><br class=""></div><div class=""><font face="Courier" class="">ensure foo != nil else {</font></div><div class=""><font face="Courier" class="">&nbsp; &nbsp;return;</font></div><div class=""><font face="Courier" class="">}</font></div><div class=""><br class=""></div><div class="">-John</div></body></html>