Not that I like it, but insertNonIntersectingRemoveIntersectingContentsOf(_:) would be the stylistically consistent way to convey the right sense.<br><br><br><div class="gmail_quote"><div dir="ltr">On Tue, Feb 16, 2016 at 10:22 AM Dave Abrahams via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
on Mon Feb 15 2016, Brent Royal-Gordon &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt; wrote:<br>
<br>
&gt; I think you&#39;ve ended up with the right approach, and I understand the need to move on, but...<br>
&gt;<br>
&gt;&gt;     /// Returns the set of elements contained in `self` or in `other`, but not in both `self` and `other`.<br>
&gt;&gt;     /// EXISTING: exclusiveOr<br>
&gt;&gt;     @warn_unused_result<br>
&gt;&gt;     func invertingIntersection(other: Self) -&gt; Self<br>
&gt;&gt;<br>
&gt;&gt;     /// Replaces `self` with a set containing all elements contained in either `self` or `other`, but not both.<br>
&gt;&gt;     /// EXISTING: exclusiveOrInPlace<br>
&gt;&gt;     mutating func invertIntersection(other: Self)<br>
&gt;<br>
&gt; I&#39;m not quite happy with these. I don&#39;t like that the mutating form of<br>
&gt; `intersection` is `intersect`, but the mutating form of<br>
&gt; `invertingIntersection` is `invertIntersection`—it seems like both<br>
&gt; methods should change the &quot;intersection&quot; part.<br>
&gt;<br>
&gt; Have you considered going the opposite direction and combining the verb &quot;intersect&quot; with the adjective &quot;inverse&quot;?<br>
&gt;<br>
&gt;     /// Returns the set of elements contained in `self` or in `other`, but not in both `self` and `other`.<br>
&gt;     /// EXISTING: exclusiveOr<br>
&gt;     @warn_unused_result<br>
&gt;     func inverseIntersection(other: Self) -&gt; Self<br>
&gt;<br>
&gt;     /// Replaces `self` with a set containing all elements contained in either `self` or `other`, but not both.<br>
&gt;     /// EXISTING: exclusiveOrInPlace<br>
&gt;     mutating func inverseIntersect(other: Self)<br>
&gt;     // or perhaps even `inverselyIntersect` so it&#39;s an adverb<br>
&gt;<br>
&gt; I wouldn&#39;t be surprised if you did, because I could see you trying to<br>
&gt; dodge the adverb problem, but I thought it was worth asking.<br>
<br>
These names all have the wrong sense, including the ones that were<br>
decided upon.  “Inverting the intersection” doesn&#39;t imply that elements<br>
not in the intersection will be merged, which is what happens in a<br>
symmetric difference.<br>
<br>
--<br>
-Dave<br>
<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>