<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class=""><font color="#333333" class="">I'm generally in favor of the proposed changes. I'll just note some minor points and disagreements:</font></div><div class=""><br class=""></div><div class=""><font color="#333333" class=""><br class=""></font></div><div class=""><font color="#333333" class="">* Like I mentioned in my SE-0023 review, I would be OK with keeping the "Type" suffix for protocols but have no strong preference.</font></div><div class=""><font color="#333333" class=""><br class=""></font></div><div class=""><font color="#333333" class="">* I'm in favor of keeping `precondition()`. `require()` might be easier to grasp at first but personally I really came to like `precondition()`.</font></div><div class=""><font color="#333333" class="">It fells both precise and I prefer the passive </font><span style="color: rgb(51, 51, 51);" class="">`precondition()` to the active `require()` for this case. To me it fits the primary meaning better; stating an API contract. The fact that the condition is actively checked is secondary to that.</span></div><div class=""><font color="#333333" class=""><br class=""></font></div><div class=""><font color="#333333" class="">* I also agree with Radosław in that I prefer `removeAll(keepCapacity: Bool)` to</font> `removeAll(keepingCapacity: Bool)`.</div><div class=""><br class=""></div><div class="">* What is the rationale for moving `unsafeUnwrap` into Optional but not `unsafeAddressOf` into AnyObject? I can certainly see the safety argument against moving it but I don't see how that would apply to `unsafeAddressOf` but not `unsafeUnwrap`?</div><div class=""><br class=""></div><div class="">* `EnumeratedSequence` and `Repeated` feel weird to me. They make sense given the API guidelines and the previous `EnumerateSequence` and `Repeat` were a bit clunky as well but these somehow feel a bit worse... That might be wholly subjective though and I don't really have a good suggestion. The only thing that came to mind was `EnumerationSequence` and `Repetition` but I'm not overly fond of those either especially not to the point of deviating from the norm...</div><div class=""><font color="#333333" class=""><br class=""></font></div><div class=""><font color="#333333" class="">* This is not a disagreement but I'd be interested in hearing the reasons for replacing Generator(Type) with Iterator(Protocol) if someone finds the time. I can speculate of course but it's probably easier for someone to give me a short summary :-)</font></div><div class=""><font color="#333333" class=""><br class=""></font></div><div class=""><div class=""><font color="#333333" class="">* Typo: </font></div><div class=""><blockquote type="cite" class=""><span style="color: rgb(51, 51, 51);" class="">+ public func take() -> Memory // Should be Pointee</span></blockquote></div></div><div class=""><br class=""></div><div class=""><font color="#333333" class=""><br class=""></font></div></div></div><div class="">
<div class="">- Janosch</div>
</div>
<br class=""></body></html>