<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class="">Strong -1.</div><div class=""><br class=""></div><div class="">The readability arguments for ++ and — make no sense to me given that it is much more obvious, refactorable, and declarative to use</div><div class=""><br class=""></div><div class="">x = x.successor()</div><div class=""><br class=""></div><div class="">and</div><div class=""><br class=""></div><div class="">x = x.predecessor()</div><div class=""><br class=""></div><div class="">in their place. &nbsp;++ and -- outside of loops are a code smell, and even within loops can easily be mistaken for one another or misused. &nbsp;As others have no doubt pointed out, if you want them back then define the operators yourself. &nbsp;Otherwise, I can’t say I’ve mourned the loss of these things enough to consider their reintroduction.</div><div class=""><br class=""></div><div class="">~Robert Widmann</div><br class=""><div><blockquote type="cite" class=""><div class="">On Jan 30, 2016, at 1:12 PM, Vanderlei Martinelli via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class=""><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">Hello everybody.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">I see Swift as a member of “C family" (a granddaughter/grandson of C, a daughter/son of Objective-C). OK, she/he is different and has her/his own personality like a daughter/son should be and have, but I still like to see Swift and recognize some traces that I know are things that became from C.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">This said, I would like to say that after the removal of `++` and `--` my code becomes less readable and more prone to errors. There were two characters to differentiate an addition from a subtraction, now there is only one (`+= 1`, `-= 1`). Also the character keys are very close in the US keyboard so it is easier to make a mistake and is not as simple as the previous solution when I typed two times the same key. Using Erica's way of saying certain things: I do not love the removal of `++` and `--`.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">I do not know how far the Swift is to the adolescence, but it is certain that teenagers are rebels. There's something very good at it. In most cases they are to be certain. But in some things they regret later. Now I see that many of us want to replace the `??` operator to something else. I'm wondering the next steps...&nbsp; To replace the `&amp;&amp;`, `||` and `!` operator with `and`, `or`, `not`? I’m not "loving" this as well.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">Are these changes really necessary for the Swift evolution? Is it the better path to deny its origin and to try to fix what is not broken? I would like you to think about it.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">There are many other things that really need to be improved and repaired and other things needed to are created. Those mentioned here in this message does not seem to fit it.</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">Regards,</div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class=""><br class=""></div><div style="margin: 0px; font-size: 11px; line-height: normal; font-family: Helvetica;" class="">-Van</div></div>
_______________________________________________<br class="">swift-evolution mailing list<br class=""><a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a><br class="">https://lists.swift.org/mailman/listinfo/swift-evolution<br class=""></div></blockquote></div><br class=""></body></html>