<div dir="ltr">Hello. <span style="font-size:13px">I also like the alternative: keep ++ and -- while returning void. :-)</span></div><div class="gmail_extra"><br><div class="gmail_quote">On Sat, Jan 30, 2016 at 5:00 PM, Will Stanton <span dir="ltr">&lt;<a href="mailto:willstanton1@yahoo.com" target="_blank">willstanton1@yahoo.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello Van,<br>
<br>
I think you make some good points about readability, and I do not recall the retention of ‘++’ and ‘--&#39; being discussed much, perhaps since SE-0004 and 0007 were accepted. All the same:<br>
<br>
At first, I really disliked the removal of ++ and --. In my opinion, the first three disadvantages in SE-0004 (<a href="https://github.com/apple/swift-evolution/blob/master/proposals/0004-remove-pre-post-inc-decrement.md" rel="noreferrer" target="_blank">https://github.com/apple/swift-evolution/blob/master/proposals/0004-remove-pre-post-inc-decrement.md</a>) were not that strong:<br>
<br>
&gt; These operators increase the burden to learn Swift as a first programming language - or any other case where you don&#39;t already know these operators from a different language.<br>
<br>
 ‘++’ does not seem less obvious than ‘+=’ and learning about the 2-4 extra operators doesn’t seem burdensome.<br>
++ and -- are also not particularly rare (I remember being surprised that Python did not support them)<br>
<br>
&gt; Their expressive advantage is minimal - x++ is not much shorter than x += 1.<br>
Still, `++` is easier to type than `+= 1`<br>
<br>
&gt; Swift already deviates from C in that the =, += and other assignment-like operations returns Void (for a number of reasons). These operators are inconsistent with that model.<br>
<br>
I liked the alternative considered: keep ++ and -- while returning void<br>
<br>
<br>
<br>
But over a few days I became less bothered by the proposal. I agreed with this:<br>
&gt; Swift has powerful features that eliminate many of the common reasons you&#39;d use ++i in a C-style for loop in other languages, so these are relatively infrequently used in well-written Swift code. These features include the for-in loop, ranges, enumerate, map, etc.<br>
<br>
<br>
I respectfully disagree with removing the operators but also don’t have strong objections.<br>
<br>
Regards,<br>
Will Stanton<br>
<div class="HOEnZb"><div class="h5"><br>
&gt; On Jan 30, 2016, at 1:12 PM, Vanderlei Martinelli via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br>
&gt;<br>
&gt; Hello everybody.<br>
&gt;<br>
&gt; I see Swift as a member of “C family&quot; (a granddaughter/grandson of C, a daughter/son of Objective-C). OK, she/he is different and has her/his own personality like a daughter/son should be and have, but I still like to see Swift and recognize some traces that I know are things that became from C.<br>
&gt;<br>
&gt; This said, I would like to say that after the removal of `++` and `--` my code becomes less readable and more prone to errors. There were two characters to differentiate an addition from a subtraction, now there is only one (`+= 1`, `-= 1`). Also the character keys are very close in the US keyboard so it is easier to make a mistake and is not as simple as the previous solution when I typed two times the same key. Using Erica&#39;s way of saying certain things: I do not love the removal of `++` and `--`.<br>
<br>
</div></div></blockquote></div><br></div>