I would have no such qualms. To me array.iterator reads better that array.iterator(). There is precedence for this approach also; Scala. In Scala they go even further, if you declare a function with no args you can always call it without brackets. This works well in Scala and mixes well with their properties that are very similar to Swift properties (though different syntax).<br><br>On Thursday, 28 January 2016, Dave Abrahams &lt;<a href="mailto:dabrahams@apple.com">dabrahams@apple.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
on Wed Jan 27 2016, Howard Lovatt &lt;<a href="http://howard.lovatt-AT-gmail.com" target="_blank">howard.lovatt-AT-gmail.com</a>&gt; wrote:<br>
<br>
&gt; I would say that if it doesn&#39;t have arguments and doesn&#39;t mutate then it<br>
&gt; should be a property, since it will read better and is flexible (you can<br>
&gt; switch between a stored and calculated property without affecting the<br>
&gt; external interface easily).<br>
<br>
We had at least one member of the guidelines group initially felt *very*<br>
strongly that we should use (basically) that criterion.  But then, in<br>
our survey of the standard library, we found that applying it left us<br>
with many properties that he wasn&#39;t comfortable with, such as<br>
`sequence.iterator` (today&#39;s `sequence.generate()`).<br>
<br>
&gt; On Thursday, 28 January 2016, David Waite via swift-evolution &lt;<br>
&gt; <a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;swift-evolution@swift.org&#39;)">swift-evolution@swift.org</a>&gt; wrote:<br>
&gt;<br>
&gt;&gt; IMHO, there are safety-level consistency aspects below the<br>
&gt;&gt; design/consistency aspects.<br>
&gt;&gt;<br>
&gt;&gt; From a safety perspective, people expect property and subscript getters to<br>
&gt;&gt; behave like pure functions (at least externally) - calling does not change<br>
&gt;&gt; the state. Whether I get a collection’s count once at the start of my loop<br>
&gt;&gt; or for each iteration of my loop, both will give me safe behavior.<br>
&gt;&gt;<br>
&gt;&gt; People expect property setters to be idempotent - if they mutate an<br>
&gt;&gt; object, calling a setter again will result in the same object<br>
&gt;&gt; representation (at least externally) and not further mutation.<br>
&gt;&gt;<br>
&gt;&gt; Once you have the safety aspect underway, usability and consistency<br>
&gt;&gt; determine what stays as properties or gets promoted to methods.<br>
&gt;&gt;<br>
&gt;&gt; Example: from a safety perspective, “reverse” and many other methods could<br>
&gt;&gt; be getter property on CollectionType. However, they could not be properties<br>
&gt;&gt; on the super type SequenceType, because SequenceType is allowed to consume<br>
&gt;&gt; the underlying data. To have “reverse’ be consistent across both<br>
&gt;&gt; SequenceType and its subtype CollectionType, it needs to be a method.<br>
&gt;&gt;<br>
&gt;&gt; underestimateCount() looks like it could be a property for safety, but<br>
&gt;&gt; some other design/consistency aspects made it a method.<br>
&gt;&gt;<br>
&gt;&gt; -DW<br>
&gt;&gt;<br>
&gt;&gt; &gt; On Jan 27, 2016, at 12:23 PM, Dave Abrahams via swift-evolution &lt;<br>
&gt;&gt; <a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;swift-evolution@swift.org&#39;)">swift-evolution@swift.org</a> &lt;javascript:;&gt;&gt; wrote:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; I&#39;m glad you mentioned this, Jacob.  We had extensive internal<br>
&gt;&gt; &gt; discussions about properties, and made substantial progress, but we do<br>
&gt;&gt; &gt; not yet have wording suitable for the guidelines.  Let me tell you where<br>
&gt;&gt; &gt; things stand.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; ,----[ Side Note, since you mentioned efficiency ]<br>
&gt;&gt; &gt; | I originally wanted to uphold the principle that, “if it isn&#39;t O(1),<br>
&gt;&gt; you<br>
&gt;&gt; &gt; | don&#39;t make it a property.”  The implication is that on collections,<br>
&gt;&gt; &gt; | “count” would be a method.  That would include Array, for which<br>
&gt;&gt; counting<br>
&gt;&gt; &gt; | the elements *is* O(1).  Some people argued that:<br>
&gt;&gt; &gt; |<br>
&gt;&gt; &gt; | 1. The idea of writing “a.count()” instead of “a.count” to count the<br>
&gt;&gt; &gt; |    elements of an Array was absurd.<br>
&gt;&gt; &gt; | 2. Programmers don&#39;t draw conclusions about efficiency based on whether<br>
&gt;&gt; &gt; |    something is a property.<br>
&gt;&gt; &gt; | 3. The fact that Array would have an O(1) non-property that *could*<br>
&gt;&gt; have<br>
&gt;&gt; &gt; |    been a property (if it weren&#39;t for CollectionType conformance)<br>
&gt;&gt; &gt; |    undermines any communicative power that you might get from using<br>
&gt;&gt; this<br>
&gt;&gt; &gt; |    distinction to choose properties.<br>
&gt;&gt; &gt; |<br>
&gt;&gt; &gt; | I did not win that argument :-)<br>
&gt;&gt; &gt; `----<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; So we surveyed the entire standard library, trying to arrive at some<br>
&gt;&gt; &gt; consensus about what ought to be a property and what ought not to be<br>
&gt;&gt; &gt; one.  Fortunately I happen to already have a write-up of those results:<br>
&gt;&gt; &gt; <a href="https://gist.github.com/dabrahams/b6b79f19c2bf9b2a0083" target="_blank">https://gist.github.com/dabrahams/b6b79f19c2bf9b2a0083</a><br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; The parts I&#39;m not currently satisfied with are:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; 1. I don&#39;t know how to nail down what was meant by “intrinsic” in:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt;     Things that are “intrinsic” to the receiver are properties<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; 2. (possibly-related): The following don&#39;t seem (to me) to be a clear<br>
&gt;&gt; &gt;   fit for any of the criteria.  I think we made the right decision in<br>
&gt;&gt; &gt;   most cases, but I don&#39;t know how to describe why:<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt;   * description, debugDescription, customReflectable.customMirror<br>
&gt;&gt; &gt;   * first<br>
&gt;&gt; &gt;   * unsafePointer.pointee<br>
&gt;&gt; &gt;   * string.utf8.nulTerminatedUTF8<br>
&gt;&gt; &gt;   * collection.min()<br>
&gt;&gt; &gt;   * sequence.iterator()<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; 3. I don&#39;t understand the rationale we currently have for<br>
&gt;&gt; &gt;   sequence.iterator() not being a property, even though I think that&#39;s<br>
&gt;&gt; &gt;   the right choice.<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; I *do* think there&#39;s enough here to eventually turn it into wording for<br>
&gt;&gt; &gt; the guidelines, but it&#39;s going to take a little more work.  If the<br>
&gt;&gt; &gt; community can help us clarify the points above, I&#39;m sure it could be a<br>
&gt;&gt; &gt; big help!<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; Cheers,<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; --<br>
&gt;&gt; &gt; -Dave<br>
&gt;&gt; &gt;<br>
&gt;&gt; &gt; _______________________________________________<br>
&gt;&gt; &gt; swift-evolution mailing list<br>
&gt;&gt; &gt; <a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;swift-evolution@swift.org&#39;)">swift-evolution@swift.org</a> &lt;javascript:;&gt;<br>
&gt;&gt; &gt; <a href="https://lists.swift.org/mailman/listinfo/swift-evolution" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
&gt;&gt;<br>
&gt;&gt; _______________________________________________<br>
&gt;&gt; swift-evolution mailing list<br>
&gt;&gt; <a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;swift-evolution@swift.org&#39;)">swift-evolution@swift.org</a> &lt;javascript:;&gt;<br>
&gt;&gt; <a href="https://lists.swift.org/mailman/listinfo/swift-evolution" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
&gt;&gt;<br>
<br>
--<br>
-Dave<br>
</blockquote><br><br>-- <br>  -- Howard.<br><br>