<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div><blockquote type="cite" class=""><div class="">On Jan 24, 2016, at 11:06 AM, Jacob Bandes-Storch &lt;<a href="mailto:jtbandes@gmail.com" class="">jtbandes@gmail.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class="">Just to clarify, are you suggesting that the mutating version would be "applySine()", and the nonmutating version would be "applyingSine()”?<br class=""></div></blockquote><div><br class=""></div><div>I was thinking `applyingSine()` for the mutating version and just plain old `sin()` for the non-mutating version, or maybe even a computed property, so just `sin`. I’m not really advocating for any of these, but hoping to spur discussion or provide a creative nudge.</div><div><br class=""></div><div>Personally, I think I like the `fooInPlace()` convention. It’s unambiguous and sufficiently verbose to perhaps make people think twice about using it.</div><div><br class=""></div><div>— Curt</div><div><br class=""></div><br class=""><blockquote type="cite" class=""><div class=""><div class="gmail_quote"><div dir="ltr" class="">On Sun, Jan 24, 2016 at 10:50 AM Curt Clifton &lt;<a href="mailto:curt@omnigroup.com" class="">curt@omnigroup.com</a>&gt; wrote:<br class=""></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="auto" class=""><div class=""><br class=""></div><div class="">On Jan 24, 2016, at 12:34 AM, Jacob Bandes-Storch via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank" class="">swift-evolution@swift.org</a>&gt; wrote:<br class=""><br class=""></div><blockquote type="cite" class="">I agree that "sinInPlace()", "meanInPlace()", "remainderInPlace()" seem to work pretty well, but I'm aware that I'm drawing on experience with the old names of sortInPlace(), subtractInPlace(), etc., and in fact this case is worse because the first words aren't really verbs (you can't sine something <i class="">in place</i> any more than you can sine it). "takeSine()" doesn't sound great either.</blockquote><br class=""></div><div dir="auto" class=""><div class="">How about "applyingSine()" , "applyingMean()", and "applyingRemainder()"?&nbsp;</div><div class=""><br class=""></div><div class="">Cheers,&nbsp;</div></div><div dir="auto" class=""><div class=""><br class=""></div><div class="">Curt</div></div></blockquote></div>
</div></blockquote></div><br class=""></body></html>