<div dir="ltr">How would we apply this to delegate patterns?<div>For example, would we keep tableview(tableView:cellForRowAtIndexPath:), or would we switch to delegate(tableView:cellForRowAtIndexPath:) ?</div><div>Or perhaps better, for clarity over which protocol is being conformed to / which property of the delegator is calling the function:</div><div>dataSource(tableView:cellForRowAtIndexPath:),</div><div>delegate(tableView:didSelectRowAtIndexPath:)</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Sat, Jan 23, 2016 at 12:00 AM, David Owens II via swift-evolution <span dir="ltr">&lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><blockquote type="cite"><div><div><b>Compensate For Weak Type Information as needed to clarify a parameter’s role.<br></b></div><div><br></div>Especially when a parameter type is NSObject, Any, AnyObject, or a fundamental type such Int or String, type information and context at the point of use may not fully convey intent. In this example, the declaration may be clear, but the use site is vague:<br><br></div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><div><font face="Menlo">func add(observer: NSObject, for keyPath: String)</font></div></div><div><div><font face="Menlo">grid.add(self, for: graphics) // vague</font></div></div></blockquote><div><br>To restore clarity, precede each weakly-typed parameter with a noun describing its role:<br><br></div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><font face="Menlo">func addObserver(_ observer: NSObject, forKeyPath path: String)</font></div><div><div><font face="Menlo">grid.addObserver(self, forKeyPath: graphics) // clear</font></div></div></blockquote></blockquote><div><br></div><div>I don’t understand why to compensate for weak type information we put some of that compensation in the name of the function and other parts of it in the [external] name of the parameter.</div><div><br></div><div>If we were going to reference functions like this: addObserver:forKeyPath, then I can understand it. But that’s not the plan of record, it’s to do this: addObserver(_:forKeyPath). </div><div><br></div><div>Regardless of the default naming scheme, it seems like the rule should be to use external names to clarify that parameters role.</div><div><br></div><div><blockquote style="margin:0px 0px 0px 40px;border:none;padding:0px"><div><font face="Menlo">func add(observer observer: NSObject, forKeyPath path: String)</font></div><div><font face="Menlo">grid.add(observer: self, forKeyPath: graphics)</font></div></blockquote></div><div><br></div><div>This promotes a very clear and consistent rule: weak type information should be clarified by the parameter’s external name. There are no exceptions for the first parameter. Otherwise, it seems like there is super fine line between this rule and the next one below. </div><div><br></div><div>Additionally, this also alleviates my concerns with the default parameter have _ as the external name by default because this addresses the case when it would be desirable to have that name. Further, the case below handles the case when it’s not.</div><div><br></div><div><br></div><div><div><b></b></div></div><blockquote type="cite"><div><div><b>Omit Needless Words. Every word in a name should convey salient information at the use site.<br></b></div><div><br></div>More words may be needed to clarify intent or disambiguate meaning, but those that are redundant with information the reader already possesses should be omitted. In particular, omit words that merely repeat type information:<br><br></div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><div><font face="Menlo">public mutating func removeElement(member: Element) -&gt; Element?</font></div></div><div><div><font face="Menlo">allViews.removeElement(cancelButton)</font></div></div></blockquote><div><br>In this case, the word Element adds nothing salient at the call site. This API would be better:<br><br></div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><div><font face="Menlo">public mutating func remove(member: Element) -&gt; Element?</font></div></div><div><div><font face="Menlo">allViews.remove(cancelButton) // clearer</font></div></div></blockquote><div><br>Occasionally, repeating type information is necessary to avoid ambiguity, but in general it is better to use a word that describes a parameter’s role rather than its type. See the next item for details.</div></blockquote><div><br></div><div>The description here seems to overlap with the “Compensate for Weak Type Information” rule, especially with the clause: “repeating type information”. It may be better to re-work the example to be `removeItem(member: Element)` to make this distinction more clear that it’s not type information being removed.</div><div><br></div><div>Also, by clarifying that statement, the above rule change I suggested would be consistent. Type information clarification goes into the external parameter name, functionality clarification goes into the function name. Those are hard-n-fast rules that are straight-forward. </div><div><br></div><div><br></div><div></div><blockquote type="cite"><div><b>Be Grammatical</b></div><span class=""><div><b><br></b></div><div><div>When a mutating method is described by a verb, name its non-mutating counterpart according to the “ed/ing” rule, e.g. the non-mutating versions of x.sort() and x.append(y) are x.sorted() and x.appending(y).</div></div></span></blockquote><div><br></div><div>Is this guideline suggesting that we should design our APIs to generally have both mutating and non-mutaging counterparts?</div><div><br></div><div>As other have pointed out, this is also very hard to do all the time. I think the alternatives are worse. It would be nice if there were a way to annotate all member functions as mutating/non-mutating to really by-pass this ambiguity.</div><div><br></div><div>Other than the above, the proposal looks pretty good to me.</div><div><br></div><div>-David</div><br></div><br>_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
<br></blockquote></div><br></div>