<!DOCTYPE html>
<html>
<head>
<title></title>
</head>
<body><div>On Thu, Jan 7, 2016, at 11:23 AM, Alex Johnson via swift-evolution wrote:<br></div>
<blockquote type="cite"><div dir="ltr"><div>Meanwhile, back on the topic of the "..." placeholder.<br></div>
<div>&nbsp;</div>
<div><div>For me, it boils down to:<br></div>
<div><ol><li>The addition of the "memberwise" keyword and associated behavior would stand on it's own, without the inclusion of the "..." placeholder syntax. (IMO)<br></li><li>Omitting the "..." placeholder syntax <i>now</i>&nbsp;wouldn't prevent it from being added <i>later</i>.<br></li></ol><div>If you agree with those statements, then the principle of "<a href="https://swift.org/contributing/#incremental-development">smallest, incremental change</a>" [<a href="http://swift.org">swift.org</a>] seems to imply that the placeholder should be removed from this proposal.<br></div>
</div>
<div>&nbsp;</div>
<div>That's my opinion. Does the rest of the community feel that the "..." placeholder is a <i>necessary</i> part of this proposal?<br></div>
</div>
</div>
</blockquote><div>&nbsp;</div>
<div>Yes, I feel that the "..." placeholder is necessary. I cannot support a proposal that results in<br></div>
<div>&nbsp;</div>
<div>memberwise init() {}<br></div>
<div>&nbsp;</div>
<div>because that initializer very clearly takes no arguments! The "..." serves as a visual indicator for where the arguments go and I think that's important.<br></div>
<div>&nbsp;</div>
<div>Also, and though this isn't explicitly spelled out in the proposal it seems like a reasonable assumption to make, the existence of "..." lets me put it somewhere other than at the end of the arguments list, e.g.<br></div>
<div>&nbsp;</div>
<div>memberwise init(..., foo: String) {}<br></div>
<div>&nbsp;</div>
<div>-Kevin Ballard</div>
</body>
</html>