<div dir="ltr"><div>On Thu, Jan 7, 2016 at 11:02 AM, Joe Groff <span dir="ltr">&lt;<a href="mailto:jgroff@apple.com" target="_blank">jgroff@apple.com</a>&gt;</span> wrote:<br></div><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div style="word-wrap:break-word"><span><br><div><blockquote type="cite"><div>On Jan 7, 2016, at 10:59 AM, Jacob Bandes-Storch via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>&gt; wrote:</div><br><div><div class="gmail_extra" style="font-family:Helvetica;font-size:12px;font-style:normal;font-variant:normal;font-weight:normal;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px">       <span> </span><b>do let</b><span> </span>value2 = somethingNonOptional()</div><br></div></blockquote></div><br></span><div>&#39;case let&#39; already works like this, by declaring a pattern &#39;let a&#39; that unconditionally matches anything.</div><span><font color="#888888"><div><br></div><div>-Joe</div></font></span></div></blockquote></div><div class="gmail_extra"><br></div>You learn something new every day on this list!<div><br></div><div>This effectively solves the problems I&#39;ve had. However, I think the resulting code is misleading, because &quot;if case let&quot; or just &quot;case let&quot; look like conditional expressions, when really they aren&#39;t.</div><div><br></div><div>    if case let x = somethingNonOptional() {</div><div>        // use x, <b>unconditionally</b></div><div>    } // x out of scope now<br></div><div><br></div><div>I think &quot;do let&quot; would improve readability considerably...</div></div></div>