<div>Hi all, hope I’m not adding to what has already been said.</div><div><br></div><div>Instead of:</div><div><br></div><div>let fn = someView.insertSubview(_:at:)</div><div><br></div><div>Could you have:</div><div><br></div><div>let fn = someView.insertSubview(_ at: _)</div><div><br></div><div>Basically like unused parameters in reverse.</div><div><br></div><div>Filling out all parameters with _ would return a function to the method, like the behaviour proposed. The advantages would be consistency, readability, and compatibility with autocomplete.</div><div><br></div><div>Additionally this could possibly lead to partial parameter application, but that’s outside the scope of what is being discussed.</div><div><br></div><div>Patrick</div>