<div dir="ltr">Am I too late to throw in more off-the-cuff suggestions?<div><br></div><div>protocol SequenceType {</div><div> having Generator</div><div>}</div><div><br></div><div>protocol SequenceType<having Generator> { } // in the protocol signature, but distinct from a generic param</div><div><br></div><div>protocol SequenceType<any Generator> // same idea</div><div class="gmail_extra"><br></div><div class="gmail_extra"><br clear="all"><div><div><div dir="ltr"><div>Jacob Bandes-Storch<br></div></div></div></div>
<br><div class="gmail_quote">On Sat, Dec 19, 2015 at 8:37 PM, Kelly Gerber via swift-evolution <span dir="ltr"><<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I believe Scala uses just “type” for abstract type members. Is that too short? If too short, then how about “typemember”? Or perhaps “abstractype”?<br>
<br>
-Kelly<br>
<div><div><br>
> Hi,<br>
><br>
> I’m starting a new thread for this proposal <a href="https://github.com/apple/swift-evolution/blob/master/proposals/0011-replace-typealias-associated.md" rel="noreferrer" target="_blank">https://github.com/apple/swift-evolution/blob/master/proposals/0011-replace-typealias-associated.md</a><br>
><br>
> So far, everybody agreed that using distinct keywords for type alias and associated type declarations is a good idea.<br>
> However, some people think that “associated” is not an ideal replacement because it is too vague.<br>
> I would like to choose a better keyword before the review, but I’m struggling to find a good replacement.<br>
><br>
> So, here are some keywords that were proposed by the community.<br>
><br>
> 1. associated_type<br>
> This is the original proposed keyword. It is extremely clear, but snake_cases are un-Swifty.<br>
><br>
> 2. associatedtype (or typeassociation)<br>
> This was the first alternative to associated_type. Its purpose is still extremely clear.<br>
> I like it a lot, but it is a bit long and difficult to read.<br>
><br>
> 3. associated<br>
> This is the keyword I chose for the proposal because it was the most well-received initially.<br>
> It is quite short, very different from “typealias", and sounds good. However, it is also vaguer.<br>
> Because the word “type” is not in it, it’s unclear what should follow it, and it’s unclear what it declares.<br>
> For example, one could think that it is an associated *value* and write<br>
> protocol FixedSizeCollectionProtocol {<br>
> associated size : Int<br>
> }<br>
> Although honestly I doubt many people would write that.<br>
><br>
> 4. withtype (or needstype)<br>
> It is short, somewhat easy to read, has the word “type” in it, and some concept of association thanks to “with”. I like it.<br>
> But it doesn’t sound very good, and is still vaguer than “associatedtype”.<br>
><br>
> 5. type<br>
> This keyword was proposed by several people, but I strongly dislike it.<br>
> It conflicts with an other proposal about unifying the “static” and “class” keywords for type-level members.<br>
> I think the fact that it was proposed for two completely different purposes shows that it is too abstract.<br>
> It would make searching for help more difficult because of its bad googleability.<br>
><br>
><br>
> Personally, I would like to either keep “associated”, or use “associatedtype” because they are the most obvious choices.<br>
><br>
</div></div><span>> 1) Do you agree about using “associatedtype”?<br>
> 2) If not, which keyword would you prefer to use? why? (you can introduce a new one)<br>
</span><span>> Bonus) Maybe some twitter-famous person could make a quick poll and see which one developers prefer? 😁 (after they read this email)<br>
> I would gladly do it myself, but I don’t think my twenty (mostly fake) followers will give me a lot of information.<br>
><br>
> Loïc<br>
><br>
><br>
</span><div><div>_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</div></div></blockquote></div><br></div></div>