<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Matthew,<div class=""><br class=""></div><div class="">Understood, I just wanted to link the conversations together.</div><div class=""><br class=""></div><div class="">As for the idea, I am a huge fan of removing the necessary $0.</div><div class=""><br class=""></div><div class="">-Sean</div><div class=""><br class=""><div><blockquote type="cite" class=""><div class="">On Dec 18, 2015, at 7:57 AM, Matthew Johnson &lt;<a href="mailto:matthew@anandabits.com" class="">matthew@anandabits.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="content-type" content="text/html; charset=utf-8" class=""><div dir="auto" class=""><div class="">Thanks for lining to the original thread Sean. &nbsp;I should have done that myself.</div><div class=""><br class=""></div><div class="">I started a new thread as this is really an independent feature that is related to the spread operator but stands on its own. &nbsp;It deserves a thread and subject line of its own.</div><div class=""><br class=""></div><div class="">Matthew</div><div class=""><br class=""></div><div class=""><br class="">Sent from my iPad</div><div class=""><br class="">On Dec 18, 2015, at 6:38 AM, Sean Kosanovich &lt;<a href="mailto:sean7512@me.com" class="">sean7512@me.com</a>&gt; wrote:<br class=""><br class=""></div><blockquote type="cite" class=""><div class=""><meta http-equiv="Content-Type" content="text/html charset=utf-8" class="">This was/is being discussed at length in this thread:&nbsp;<a href="https://lists.swift.org/pipermail/swift-evolution/Week-of-Mon-20151214/002742.html" class="">https://lists.swift.org/pipermail/swift-evolution/Week-of-Mon-20151214/002742.html</a><div class=""><br class=""></div><div class=""><br class=""></div><div class=""><br class=""><div class=""><blockquote type="cite" class=""><div class="">On Dec 17, 2015, at 10:27 PM, Matthew Johnson via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><div class="">Swift currently offers dot shorthand for static members of type Self in type contexts expecting a value of the type in question. &nbsp;This is most commonly used with enum cases.<br class=""><br class="">Swift does not currently offer shorthand for instance members. &nbsp;Introducing a shorthand for instance members would improve clarity and readability of code in common cases:<br class=""><br class="">anArray.map{$0.anInstanceMethod()}<br class=""><br class="">becomes:<br class=""><br class="">anArray.map(.anInstanceMethod())<br class=""><br class="">This shorthand would work in typing contexts expecting a single argument function. &nbsp;It would allow abbreviated access to any visible instance property getter or instance method on the type of the argument. &nbsp;Of course the return type would need to match the return type expected by the context or a type mismatch compiler error would occur.<br class=""><br class="">The readability advantage is arguably small but it does exist. &nbsp;The feature also aligns very well with an existing language feature.<br class=""><br class="">I think it’s an interesting idea and am wondering whether others feel like it is something worth pursuing or not.<br class=""><br class="">Matthew<br class="">_______________________________________________<br class="">swift-evolution mailing list<br class=""><a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a><br class=""><a href="https://lists.swift.org/mailman/listinfo/swift-evolution" class="">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br class=""></div></div></blockquote></div><br class=""></div></div></blockquote></div></div></blockquote></div><br class=""></div></body></html>