<div dir="ltr">Hi all,<div><br></div><div>Swift is said to be a verbose and easy to read programming language. However, I see Swift is still using cryptic symbols for logical operators.</div><div><br></div><div>! for not</div><div>|| for or<br></div><div><div>&& for and</div><div><br></div><div>Here I propose a new logical operators that are more swiftish.</div><div><br></div><div>'not' for not</div><div>'or' for or</div><div>'and' for and</div><div><br></div><div>So, instead of:</div><div><br></div><div>if !foo1 || foo2 && foo3 { … }</div><div><br></div><div>we could write it as:</div><div><br></div><div>if not foo1 or foo2 and foo3 { … }</div><div><br></div><div>which is much more readable because it's less cryptic.</div><div><br></div><div>What do you think?</div><div><br></div><div>Thank you.</div><div><br></div><div>Regards,</div><div><br></div>-- <br><div class="gmail_signature"><div dir="ltr"><div>-Bee-<br><br></div></div></div>
</div></div>