[swift-evolution] 100% bikeshed topic: DictionaryLiteral

Brent Royal-Gordon brent at architechies.com
Tue Jan 16 14:57:22 CST 2018

> On Jan 13, 2018, at 1:40 PM, Erica Sadun <erica at ericasadun.com> wrote:
>> On Jan 9, 2018, at 10:22 PM, Brent Royal-Gordon via swift-evolution <swift-evolution at swift.org> wrote:
>> If we can't do this, I think we should call it something like `PairArray` or `KeyValueArray` 
> Or "KeyValueList", which avoids both "Dictionary" and "Array" words.

I specifically want "Array" in the name, because this type has the same semantics as an array:

* RandomAccessCollection
* Contiguous, zero-based Int indices
* Isn't currently, but could be, MutableCollection and RangeReplaceableCollection

Brent Royal-Gordon

More information about the swift-evolution mailing list