[swift-evolution] [REVIEW] SE-0193 - Cross-module inlining and specialization
brent at architechies.com
Wed Dec 20 23:34:54 CST 2017
> On Dec 20, 2017, at 7:01 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
> My one bikeshedding issue here is the name @abiPublic, which smells too much like fileprivate in my subjective opinion. A more concrete objection here is the very much non-ideal juxtaposition of two different access modifier terms in the "@abiPublic internal" spelling. It would seem to me that "@abi" would suffice instead. Indeed, the fact that it's an "interface" implies a certain level of visibility, which in my view is more precise than coopting the term "public"--that term in turn has an established meaning in Swift that, by construction, an "@abiPublic internal" method does not fulfill.
I concur. If we don't care about its ungainly size, the blindingly obvious solution would be `@inlineCallable`. Another solution might be to declare the symbol with a combination like `@hidden public`, which I assume is a closer representation of how this feature is actually implemented.
(Incidentally, the proposal doesn't mention `open`; I suspect that it probably should.)
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution