[swift-evolution] [swift-evolution-announce] [Accepted with revisions] SE-0187 “Introduce Sequence.filterMap(_:)”
brent at architechies.com
Tue Dec 19 16:08:51 CST 2017
> On Dec 19, 2017, at 8:56 AM, John McCall <rjmccall at apple.com> wrote:
> Therefore, SE-0187 is accepted, with the revision that the new name be Sequence.compactMap(_:), and with the agreement that we will add Sequence.compact() when it is possible to do so.
I like `compact` as the basis for the name, but I hope the core team will consider whether the eventual nil-removal method should be called `compacting()`, and whether therefore this method should be called `compactingMap(_:)`. Prior art on the name `compact()` does exist, but I don't think it's strong enough to justify deviating from the API Guidelines.
I don't think we need a full review on this tiny issue; five minutes of the core team's time should more than suffice.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution