[swift-evolution] [Idea] [Pitch] Add `match` statement as `switch`-like syntax alternative to `if case` pattern matching

Tino Heth 2th at gmx.de
Sat Nov 18 05:40:25 CST 2017

I haven’t spend that much time on thinking about the implications, but at first sight, it sounds like a sensible idea — maybe even more useful than switch (whose behavior could be mimicked).
But switch is established, and I don’t see a realistic chance to either replace it or add a construct that is quite similar.
Afaics, it will already be hard to collect feedback, so it might be a good idea to delay the pitch until the move to Discourse is done.

More information about the swift-evolution mailing list