[swift-evolution] [Accepted and Focused Re-review] SE-0187: Introduce Sequence.filterMap(_:)
shawnce at gmail.com
Thu Nov 16 09:39:47 CST 2017
I so far am most in favor of mapSome out of the names I have seen followed
by mapAndUnwrap (however the later is growing on me).
To me the most important thing is when reading code that it is quick to
understand generally what is going on followed by discoverability of a new
comer. I think both of these are fairly clear on a quick read while a lot
of the others are heavily overloaded terms. I also they sufficiently
discoverable / learnable ... also mor so then some of the other overload
On Wed, Nov 15, 2017 at 10:07 PM Gwendal Roué via swift-evolution <
swift-evolution at swift.org> wrote:
> Le 16 nov. 2017 à 06:29, Matt Gallagher via swift-evolution <
> swift-evolution at swift.org> a écrit :
> My opinion is that filterMap is the right choice of name.
> I'm completely biased, given that I already have a Swift library that uses
> filterMap, in exactly this context, for a Reactive Programming library:
> Another popular Reactive Programming Library uses filterMap with a
> different signature, and a different meaning:
> There are already different interpretations on "filter" in "filterMap" in
> the wild.
> Gwendal Roué
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution