[swift-evolution] [Review] SE-0187: Introduce Sequence.filterMap(_:)

Brent Royal-Gordon brent at architechies.com
Mon Nov 13 18:57:10 CST 2017


> On Nov 13, 2017, at 10:11 AM, Shawn Erickson via swift-evolution <swift-evolution at swift.org> wrote:
> 
> 
> On Mon, Nov 13, 2017 at 10:02 AM C. Keith Ray via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
> 
> You said "compact" removes nil values, so I'd name it "removeNils".
> 
> Terms like "ignoring" and "skipping".

Keep in mind that this does *slightly* more than just remove nils—it also removes a level of optionality so that it isn't *possible* for there to be nils anymore. It's the difference between `if let foo = foo` and `if foo != nil`.

-- 
Brent Royal-Gordon
Architechies

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20171113/91e4cc96/attachment.html>


More information about the swift-evolution mailing list