[swift-evolution] [Review] SE-0187: Introduce Sequence.filterMap(_:)

C. Keith Ray keithray at mac.com
Mon Nov 13 12:02:45 CST 2017

> On Nov 12, 2017, at 10:54 AM, Paul Cantrell via swift-evolution <swift-evolution at swift.org> wrote:
>> On Nov 11, 2017, at 8:35 AM, Gwendal Roué via swift-evolution <swift-evolution at swift.org> wrote:
>> I'd suggest `compactMap` as an alternative name, should `filterMap` find too much resistance:
> I like that name too, though it’s probably my Ruby experience showing. I like the clarity of “compact” for nils, “filter” for booleans. I like how fluently “compactMap” reads.
> If the core team does accept this proposal, I’d trust them to take a minute to make a considered, opinionated choice about the name.

You said "compact" removes nil values, so I'd name it "removeNils".

C. Keith Ray
Senior Software Engineer / Trainer / Agile Coach / Writer
* http://www.thirdfoundationsw.com/keith_ray_resume_2014_long.pdf
* https://leanpub.com/wepntk <- buy my book?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20171113/2027b82f/attachment.html>

More information about the swift-evolution mailing list