[swift-evolution] Standard ReactiveSteam definitions for Swift

Georgios Moschovitis george.moschovitis at icloud.com
Sat Sep 23 02:24:14 CDT 2017


Copied from the corresponding Github issue, I would like to hear opinions from the broader community on this:

I am wondering if the correct 'translation' to Swift of:

```
onNext()
onError()
```

is really:

```
on(next:)
on(error:)
```

maybe something closer to Foundation's naming conventions would be:

```
didReceive(next:) or didReceive(value:)
didReceive(error:)
```

-g.



More information about the swift-evolution mailing list