[swift-evolution] [Pitch] Improve `init(repeating:count)`

Taylor Swift kelvin13ma at gmail.com
Fri Aug 18 13:23:08 CDT 2017

On Fri, Aug 18, 2017 at 1:23 PM, Erica Sadun <erica at ericasadun.com> wrote:

> I want to avoid breaking math.

it’s not that deep,,, the `for _ in 0 ..< n` loop is exactly the same thing
except more verbose. In fact, that’s how your proposed `
Array.init(count:generator:)` would be implemented. But I don’t see anyone
saying we should get rid of the underscore pattern or `@discardableResult`,,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20170818/ac1e4c7e/attachment.html>

More information about the swift-evolution mailing list