[swift-evolution] [Proposal] Change Void meaning
rjmccall at apple.com
Mon Jun 12 12:15:15 CDT 2017
> On Jun 12, 2017, at 4:48 AM, Jérémie Girault via swift-evolution <swift-evolution at swift.org> wrote:
> Hi here,
> As I tested swift4 in xcode9b1 I noticed a lot of regressions about tuples usage.
> After documenting myself about the changes which happened, I thought that they could be improved. Instead of fighting these propositions (which make sense), I wanted create a few proposal which would improve these recent changes with a few simple rules.
> My propositions are based on the recent decisions and in the continuation of SE-0110. The first one is about Void.
> Void is historically defined as the type of the empty tuple. The reason of this is that arguments were initially considered as tuple.
The dominant consideration here was always return types, not parameters. I'm not sure there was ever much point in writing Void in a parameter list, but whatever reasons there were surely vanished with SE-0066.
Note that 'void' in C was originally exclusively a return type. ANSI gave it a new purpose it with void*, but the meaning is totally unrelated.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution