I agree strongly that the syntax looks awkward — imho
var v: Vector<Int, size: 3>
would be a much better fit than
var v array 3 of Int
As much as I want to have "real" arrays, I don't think we should add new keywords for them.