[swift-evolution] [Review #2] SE-0161: Smart KeyPaths: Better Key-Value Coding for Swift
bjhomer at gmail.com
Sat Apr 8 16:18:49 CDT 2017
I love the idea of a leading and trailing backslash. It makes it much easier to read, and handles the "but what if I want to access a property of a KeyPath?" case really well.
For example, these two are clearly distinct:
let x = \Person.mother.age\.valueType
let y = \Person.mother.age.valueType\
I'm not sure why an 'age' object would have a 'valueType' property, but this variant makes it easy to handle. Even in cases where no disambiguation is required, having the trailing backslash makes it much easier to read as I'm scanning through code.
>>> On Apr 5, 2017, at 9:13 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
>>> On Wed, Apr 5, 2017 at 9:21 PM, Ricardo Parada via swift-evolution <swift-evolution at swift.org> wrote:
>>> On Apr 5, 2017, at 9:41 PM, Brent Royal-Gordon via swift-evolution <swift-evolution at swift.org> wrote:
>>> It's worth noting that, if you write `\Person.name.valueType`, this syntax is ambiguous—it could mean "make a key path for the `valueType` property on `name` property of `Person`", or it could mean "make a key path for the `name` property of `Person`, then access the key path's `valueType` property". We can solve this by always interpreting it as the former and requiring parentheses for the latter—that is, `(\Person.name).valueType`—but I thought it was worth calling out explicitly.
>> Good point.
>> I'm thinking about the hypothetical code examples from previous emails:
>> let isPuppyQualifier = \Pet.type == .dog && \Pet.age < 12
>> let familyQualifier = (\Family.pets).contains(where: isPuppyQualifier)
>> let familiesWithPuppies = Family.fetch(editingContext, familyQualifier)
> That's an interesting point. While `\` alone seems acceptable, I think it's unfortunate that we'll have `(\...)` and `\(...)` both in the language.
> Can we maybe consider instead:
> let firstFriendsNameKeyPath = \Person.friends.name\
> It is also worth mentioning that, with the sigil, the `keyPath` label may not be so necessary:
> // or, if the suggestion above is accepted
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution