[swift-evolution] [Pitch] Add an all algorithm to Sequence

Rien Rien at Balancingrock.nl
Sat Apr 1 11:17:38 CDT 2017


> On 01 Apr 2017, at 18:09, Muse M <james.lei65 at gmail.com> wrote:
> 
> At this stage, it's rather confuse to me, if return boolean, probably sizeOf and boolOf is easier for me.
> 
> boolOf(equalTo:)
> boolOf(matching:)
> 

Or:

allEqual(to: )
allMatch(_:)

or

allItemsEqual(to: )
allItemsMatch(_:)

Rien.

> On Sat, Apr 1, 2017 at 10:54 PM, Rien via swift-evolution <swift-evolution at swift.org> wrote:
> 
> > On 01 Apr 2017, at 16:10, David Hart <david at hartbit.com> wrote:
> >
> >>
> >> On 1 Apr 2017, at 11:32, Rien <Rien at Balancingrock.nl> wrote:
> >>
> >>
> >>> On 01 Apr 2017, at 10:47, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
> >>>
> >>> On Sat, Apr 1, 2017 at 3:40 AM, David Hart via swift-evolution <swift-evolution at swift.org> wrote:
> >>>
> >>>> On 1 Apr 2017, at 09:50, Brandon Trussell <brandon2k3 at gmail.com> wrote:
> >>>>
> >>>> I agree that based on the method name, I thought a collection would be returned.
> >>>
> >>> Now that I think more about it, I think you're right. It is confusing. Perhaps:
> >>>
> >>> allAre(equalTo: )
> >>> allAre(matching: )
> >>>
> >>> Well, if we're going to go full stdlib naming guidelines, shouldn't they be--
> >>>
> >>> ```
> >>> areAll(equalTo:)
> >>> areAll(matching:)
> >>> ```
> >>
> >>
> >> thatAre(equalTo: )
> >> thatAre(matching: )
> >
> > That would be confusing again. You'd get the impression that the functions are returning elements of the Sequence, not a Bool.
> 
> Yup. my bad.
> 
> Rien.
> 
> 
> >
> >> Regards,
> >> Rien
> >>
> >> Site: http://balancingrock.nl
> >> Blog: http://swiftrien.blogspot.com
> >> Github: http://github.com/Balancingrock
> >> Project: http://swiftfire.nl
> >>
> >>
> >>>
> >>>> On Sat, Apr 1, 2017 at 12:36 AM, David Hart via swift-evolution <swift-evolution at swift.org> wrote:
> >>>>
> >>>>
> >>>>> On 1 Apr 2017, at 06:02, Will Stanton via swift-evolution <swift-evolution at swift.org> wrote:
> >>>>>
> >>>>> +1 to adding, but the name `all` suggests (to me) the return of another sequence, not a Bool.
> >>>>
> >>>> I'm not too concerned because the mandatory labels makes it clear.
> >>>>
> >>>>> Perhaps the function name should be question-like?
> >>>>>
> >>>>> Suggesting: `membersSatisfy(condition:)` or `allSatisfy(condition:)` or maybe even just `satisfies(condition:)`
> >>>>> The question-like modifier/verb is necessary to suggest a Bool and IMO not a needless word.
> >>>>>
> >>>>> Regards,
> >>>>> Will Stanton
> >>>>>
> >>>>>> On Mar 31, 2017, at 11:28, Ben Cohen via swift-evolution <swift-evolution at swift.org> wrote:
> >>>>>>
> >>>>>> Hopefully non-controversial, aside from the naming of the method and arguments, about which controversy abounds
> >>>>>
> >>>>> _______________________________________________
> >>>>> swift-evolution mailing list
> >>>>> swift-evolution at swift.org
> >>>>> https://lists.swift.org/mailman/listinfo/swift-evolution
> >>>>
> >>>> _______________________________________________
> >>>> swift-evolution mailing list
> >>>> swift-evolution at swift.org
> >>>> https://lists.swift.org/mailman/listinfo/swift-evolution
> >>>>
> >>>>
> >>>>
> >>>> --
> >>>> Brandon
> >>>
> >>> _______________________________________________
> >>> swift-evolution mailing list
> >>> swift-evolution at swift.org
> >>> https://lists.swift.org/mailman/listinfo/swift-evolution
> >>>
> >>>
> >>> _______________________________________________
> >>> swift-evolution mailing list
> >>> swift-evolution at swift.org
> >>> https://lists.swift.org/mailman/listinfo/swift-evolution
> 
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution



More information about the swift-evolution mailing list